Boot Device LED Stays Red after Starting Computer Normally

Sep 26, 2018
3
0
10
0
I have done a lot of searching on the forums so far, but I thought that I would make a post of my own. This morning, I tried turning on my computer as normal, but I found that it wouldn't get past the ASUS logo screen. Upon going into the BIOS, I found that the SSD was not listed under the boot devices, and only my HDD was there. I opened the side of my case and found that the Boot Device LED was red and stayed solid.

What I have done so far:

I have tried two separate SATA data cables with the SSD, and neither seemed to work.
I have taken the SSD out and used a SATA to USB connection to see if it would be recognized, and it is recognized on my laptop.
I have tried mixing and matching the two sticks of RAM that I use, by placing them in different slots and using one at a time.
I have made sure that all of the connections are tight and correct.
I have tried plugging the SATA cable into different ports on my Motherboard, and nothing seems to work.
I have also updated my BIOS using an internet connection.

At one point during the time that I was doing the above, I saw that my SSD was recognized in BiOS, but then upon restarting my computer after I saved the settings, it was not there anymore. This is really frustrating for me because I recently reinstalled Windows 10 again after getting the blue screen of death less than a month ago.

My specs are as follows:

Motherboard: Asus Z170-A
Ram: 16 GB in Total; 1 is a 2400 MHz (Corsair Vengeance), the 2nd is a 2133 MHz (Crucial)
GPU: Nvidia Geforce GTX 960
CPU: Intel i5-6600k

A lot of other people have had success with fixing this problem through this site and I hope that I can fix my issue as well.
 

ASK THE COMMUNITY

TRENDING THREADS