Question Boot drive seemingly failed shortly after installing new HDD

Jan 25, 2022
3
0
10
0
Hello, I just installed an 8tb HDD to my gaming pc yesterday afternoon, and when I powered on my pc this morning it would only boot to bios - not to windows. In bios I can see both of my HDDs, a 2tb and 8tb, but not the SSD I have been using as a boot drive. I have tried unplugging the sata cable and replugging it in, checked all connections, tried with spare cables that I confirmed were working with the HDDs, and tried with only the SSD. The SSD is a WD Blue, and I've only had it for just under 3 years, so I find it odd that it would have failed so early, especially after just installing a new HDD the other day - the timing seems just a little too odd. However, for the life of me I can't figure it out, so I'm hoping to find some help, or someone who has an idea of what happened. My current plan, if the SSD really has failed, is to reinstall windows to the new HDD as it is blank. Thanks in advance.
 
Jan 25, 2022
3
0
10
0
is the WD blue 2.5" ssd?

full system spec? include brand and model of the psu
"
yes the ssd is the WD blue 2.5"
full specs are:
gigabyte oc 2080
intel i9-9900k @5.1ghz
32gb Corsair DDR4 Ram
EVGA 850 GQ 80+ gold psu
both hdd are seagate barracuda
asus rog strix z390-e mobo
 
EVGA 850 GQ 80+ gold psu
both hdd are seagate barracuda
Are you using original cables from this PSU?
Using wrong cables can damage/kill hardware connected.
My current plan, if the SSD really has failed, is to reinstall windows to the new HDD as it is blank.
Get a new SSD instead. Seagate Barracudas are all SMR drives - unsuitable for installing windows on them.
You'll experience 100% disk activity and bad disk performance.
 

ASK THE COMMUNITY

TRENDING THREADS