Boot from live USB Ubuntu 14.04/Mint 17 won't work!

canadianvice

Distinguished
Hello,

I'm trying to make use of an Ubuntu live USB, but here's my problem: it's worked before with no major configuration changes on the host system.
My hosting system is a Windows 7 64x. The only real oddity is a Nvidia 660Ti.

Anyhow, I've used the same USB before and never had any issues booting with it, but now I consistently get any combination of issues:
1. Black screen with blinking cursor
2. Black screen with white chunk full of ^U characters
3. Purple loading screen hangs

The only thing I've changed on the host system that I can think might be having some sort of effect on this was I'm using a VM with VMplayer to access another Ubuntu distro for my compsci courses. The issue is I can't virtualize this one because I specifically want the information to be segregated from a host OS.

Anyhow, I've used most of the major tools I've seen mentioned to try fixing this issue and I've re-torrented the Ubuntu LTS 14.04 64x version some 5 times now (from the source, ofc). I've tried Universal USB Installer (the linux one mentioned in Canonical's help documentation) the Ubuntu live USB creator (using my VM) ISO to USB, and Unetboot, all with the same end results.

I did manage (albeit slowly) to boot Ubuntu 12 off a DVD with the nomodeset. That said, not what I am looking for and the others used to work.

Any assistance is much appreciated.
 

canadianvice

Distinguished
Solution, for posterity:

It was related to my Nvidia card. What you need to do is use "Linux Live USB creator" or in theory another version of a live USB maker. Then all you have to do is, as it loads, tap e and disable --no-mode-set.

Once you've booted in the first time you can download and load the proprietary drivers for the card and boot in. Under these circumstances, anyway, that was the solution.
 

canadianvice

Distinguished
Solution, for posterity:

It was related to my Nvidia card. What you need to do is use "Linux Live USB creator" or in theory another version of a live USB maker. Then all you have to do is, as it loads, tap e and disable --no-mode-set.

Once you've booted in the first time you can download and load the proprietary drivers for the card and boot in. Under these circumstances, anyway, that was the solution.
 

ASK THE COMMUNITY