Boot Loader

G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

Running dual boot Win 98 XP SP2 - reg corruption required reinstall of XP.
Boot screen now shows XP Prof Twice, and Windows. Boot loader config
contains "XP fastdetect and XP fastdetect /NoExcute=OptIn". I would like to
get rid of one the "XP Prof" on boot up. Thanks.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

Explanation of the two switches...

/fastdetect
[[The /fastdetect parameter disables NTDETECT serial and parallel port
device detection at the specified communications ports. If you do not
specify a communications port, this parameter disables detection on all
serial and parallel ports.]]

/NoExecute=OptIn
[[This setting is the default configuration. On systems with processors that
can implement hardware-enforced DEP, DEP is enabled by default for limited
system binaries and programs that "opt-in." With this option, only Windows
system binaries are covered by DEP by default.]]
===

Start | Run | Type: msconfig | OK |
Boot.ini tab | Check All Boot Paths button |
A dialog box will open detailing the location of any invalid operating
system locations | Confirm you want to remove the entry and reboot

[[Check All Boot Paths - This button will check the boot paths for all
operating systems listed in the BOOT.INI to ensure they point to a valid
operating system. ]]

Msconfig image
http://www.winnetmag.com/Files/16/20784/msconfig.gif

===

If that doesn't help, post back with copy of your boot.ini.

To open boot.ini...

Start | Run | Type or paste: control sysdm.cpl,system,3 | Click OK |
Click the Settings button under Startup and Recovery |
Click the Edit button |

When it's open | Right click | Select All | Right click | Copy |
Paste into message.

--
Hope this helps. Let us know.
Wes

In news:3412E256-BAEB-4E0F-8542-85C6F7523AA3@microsoft.com,
navpers <navpers@discussions.microsoft.com> hunted and pecked:
> Running dual boot Win 98 XP SP2 - reg corruption required reinstall
> of XP. Boot screen now shows XP Prof Twice, and Windows. Boot loader
> config contains "XP fastdetect and XP fastdetect /NoExcute=OptIn". I
> would like to get rid of one the "XP Prof" on boot up. Thanks.
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

"Wesley Vogel" wrote:

> Explanation of the two switches...
>
> /fastdetect
> [[The /fastdetect parameter disables NTDETECT serial and parallel port
> device detection at the specified communications ports. If you do not
> specify a communications port, this parameter disables detection on all
> serial and parallel ports.]]
>
> /NoExecute=OptIn
> [[This setting is the default configuration. On systems with processors that
> can implement hardware-enforced DEP, DEP is enabled by default for limited
> system binaries and programs that "opt-in." With this option, only Windows
> system binaries are covered by DEP by default.]]
> ===
>
> Start | Run | Type: msconfig | OK |
> Boot.ini tab | Check All Boot Paths button |
> A dialog box will open detailing the location of any invalid operating
> system locations | Confirm you want to remove the entry and reboot
>
> [[Check All Boot Paths - This button will check the boot paths for all
> operating systems listed in the BOOT.INI to ensure they point to a valid
> operating system. ]]
>
> Msconfig image
> http://www.winnetmag.com/Files/16/20784/msconfig.gif
>
> ===
>
> If that doesn't help, post back with copy of your boot.ini.
>
> To open boot.ini...
>
> Start | Run | Type or paste: control sysdm.cpl,system,3 | Click OK |
> Click the Settings button under Startup and Recovery |
> Click the Edit button |
>
> When it's open | Right click | Select All | Right click | Copy |
> Paste into message.
>
> --
> Hope this helps. Let us know.
> Wes
>
> In news:3412E256-BAEB-4E0F-8542-85C6F7523AA3@microsoft.com,
> navpers <navpers@discussions.microsoft.com> hunted and pecked:
> > Running dual boot Win 98 XP SP2 - reg corruption required reinstall
> > of XP. Boot screen now shows XP Prof Twice, and Windows. Boot loader
> > config contains "XP fastdetect and XP fastdetect /NoExcute=OptIn". I
> > would like to get rid of one the "XP Prof" on boot up. Thanks.

Thanks Wes
No joy
boot.ini
[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
Professional"
/fastdetect /NOExecute=OptIn
multi()0disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
Professional"
/fastdetect
C:\="Microsoft Windows"

>
>
 
G

Guest

Guest
Archived from groups: microsoft.public.windowsxp.configuration_manage (More info?)

I am *pretty* sure that

multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
Professional"
/fastdetect /NOExecute=OptIn

Is the XP with SP2 because of the /NOExecute=OptIn switch.

multi()0disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
Professional"
/fastdetect

Would probably be the original XP installation.

C:\="Microsoft Windows"

Would be Windows 98.
===

Any data that you cannot afford to lose? Back it up first!!!!

Open the boot.ini....

Delete this line >>
multi()0disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
Professional"
/fastdetect

Make it look like this >>
[boot loader]
timeout=5
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
Professional"
/fastdetect /NOExecute=OptIn
C:\="Microsoft Windows"

Make sure that you answer YES to Save the changes when you close boot.ini.

It looks like Windows 98 will remain the default.

--
Hope this helps. Let us know.
Wes

In news:E9BF83E7-265D-4A39-95D3-F6E784F2D247@microsoft.com,
navpers <navpers@discussions.microsoft.com> hunted and pecked:
> "Wesley Vogel" wrote:
>
>> Explanation of the two switches...
>>
>> /fastdetect
>> [[The /fastdetect parameter disables NTDETECT serial and parallel
>> port device detection at the specified communications ports. If you
>> do not specify a communications port, this parameter disables
>> detection on all serial and parallel ports.]]
>>
>> /NoExecute=OptIn
>> [[This setting is the default configuration. On systems with
>> processors that can implement hardware-enforced DEP, DEP is enabled
>> by default for limited system binaries and programs that "opt-in."
>> With this option, only Windows system binaries are covered by DEP by
>> default.]] ===
>>
>> Start | Run | Type: msconfig | OK |
>> Boot.ini tab | Check All Boot Paths button |
>> A dialog box will open detailing the location of any invalid
>> operating system locations | Confirm you want to remove the entry
>> and reboot
>>
>> [[Check All Boot Paths - This button will check the boot paths for
>> all operating systems listed in the BOOT.INI to ensure they point to
>> a valid operating system. ]]
>>
>> Msconfig image
>> http://www.winnetmag.com/Files/16/20784/msconfig.gif
>>
>> ===
>>
>> If that doesn't help, post back with copy of your boot.ini.
>>
>> To open boot.ini...
>>
>> Start | Run | Type or paste: control sysdm.cpl,system,3 | Click
>> OK | Click the Settings button under Startup and Recovery |
>> Click the Edit button |
>>
>> When it's open | Right click | Select All | Right click | Copy |
>> Paste into message.
>>
>> --
>> Hope this helps. Let us know.
>> Wes
>>
>> In news:3412E256-BAEB-4E0F-8542-85C6F7523AA3@microsoft.com,
>> navpers <navpers@discussions.microsoft.com> hunted and pecked:
>>> Running dual boot Win 98 XP SP2 - reg corruption required reinstall
>>> of XP. Boot screen now shows XP Prof Twice, and Windows. Boot
>>> loader config contains "XP fastdetect and XP fastdetect
>>> /NoExcute=OptIn". I would like to get rid of one the "XP Prof" on
>>> boot up. Thanks.
>
> Thanks Wes
> No joy
> boot.ini
> [boot loader]
> timeout=5
> default=multi(0)disk(0)rdisk(1)partition(1)WINDOWS
> [operating systems]
> multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
> Professional"
> /fastdetect /NOExecute=OptIn
> multi()0disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP
> Professional"
> /fastdetect
> C:\="Microsoft Windows"