Question Boot loop after installing new ram

DestinyEA

Prominent
Nov 22, 2020
7
2
515
0
After I upgraded my Ram from 16GB to 32GB, my MB indicated a DRAM issue shown as an orange light. I searched the internet and found I needed to reseat my CPU after trying out a couple other options. I know my RAM is working fine, as I tried them in my brothers system and it worked (I also tried his RAM on my system, and the orange light still showed). After reseating the CPU, the orange light disappeared and everything was alright. I got into the asus boot screen, and after that to the American Megatrends screen. From there it instructed me to enter the BIOS via F1 and now I’m stuck in a boot loop to my BIOS. I found that my NVME is getting detected but not showing up as a Boot Priority option. It is the only drive I have, im fact no Boot options are showing at all. But when I plug in a USB stick it is shown as boot option. It’s so weird, because I didn’t tweak anything on my NVME slot and it worked without any issues before (it’s showing up in Advanced-> NVME configuration too).
My rig:
Ryzen 5900x
Asus B550 A Gaming
970 Evo 1TB
Suprim X 3070
G skill 32GB
Seasonic PX 850
Lian Li AIO
 

ASK THE COMMUNITY