Question Boot loop and no POST, which component should I be looking into?

Jun 13, 2021

Some days ago, my pc was unattended and powered on, and there was a big lightning sound. I thought "no problem, this is usual". When I went to the computer, I noticed It was turned off, but the MOBO lights were working. When I tried pressing the power switch, It didn't work. I suspect the lightning because in the same wall I have a cheap multi-contact with surge protector connected to my monitor and modem and I had to turn off and turn on the switch of the multi-contact in order to have my monitor and modem working again.

Absolutely no other electric appliances in the house were damaged. Only the computer won't turn on.

START OF TESTING-----------------------------------------------------------------------------

Here is the summary of steps taken (I'm not a pro, but love to troubleshoot things):

  1. Disconnected GPU, SSD. Left the PC with 1 stick of RAM, mobo, CPU, the AIO cooler, and case fans. (Not turning on).
  2. Disconnected and reseated every power cable from modular PSU, and mobo. (Not turning on).
  3. Since my mobo has something called "armor", I can't access the battery, but there is a "clear CMOS" button in the back. Pressed it for 40 secs. (PC tries to POST.).
At this point, for some reason, the power switch works and starts the POST process. My mobo has indicators that light at each of the post processes. Sequence: CPU>DRAM>VGA>BOOT.
After the "BOOT" indicator lights up, the pc immediately shuts down completely (cuts power) with code 00, powers on again, and repeats the process, leaving me with a boot loop. When this happens, the monitor shows the Asus Rog screen "Press DEL or F2 to enter SETUP". This screen is shown for less than a second before cutting power and starting again and is not always shown.

More tests:

  1. Disconnected the case power switch from the mobo, and the "HD audio" (PC tries to POST, shuts down after "BOOT" indicator).
  2. Connected the GPU to see what happened, and, interestingly, the POST indicator sequence now stops at CPU>DRAM>VGA. It no longer passes VGA. Nothing on the screen.
  3. Disconnected the GPU and tried posting again: Now POST indicator shows CPU>DRAM>VGA>BOOT. It passes VGA again, gets to BOOT again, and immediately shuts down and restarts. (Original scenario with GPU disconnected).
After some tries, the power switch stops working again. Need to "clr cmos" again for 40 secs in order to regain POST functionality.

  1. Reflashed BIOS with USB and MOBO back button. The process is completed successfully (as doesn't seem to require POST). I get a screen about please don't shut the computer, rewriting MC or ME I can't remember... and it shuts down and starts again.
  2. I reflashed BIOS again, to no avail.
After LOTS of tries, I got to the "American Megatrends" screen. It shows the amount of detected memory and prompts me to press a key to recover BIOS. The screen is corrupted with green artifacts, but readable. The screen is shown intermittently only for 1 second, I press the key and finally, get ASUS BIOS. I save changes (no changes) and exit. This was the ONLY time I could get to the BIOS, but the green artifacts and the flashing screen obviously concerns me.

9. Finally, as I tried to reseat the memory, I seem to have it done wrong because the POST process stopped at CPU>DRAM, and stayed there forever with code 55. BUT... the computer didn't power off and restart. I kept it there on code 55 powered on for a good 5 minutes in order to test consistency.

After this, I reseated the memory correctly, tried switching sticks, different slots, and lost the ability to power on again. Tried to "clr cmos" about 3 times, and since I didn't regain the ability to try to POST I got desperate and stopped trying.
The PSU has a "fan test" button, and it works.

END OF TESTING ---------------------------------------------------------------------------------

When I built the computer in 2019, I didn't cheap out on parts because I thought I would be somewhat protected from something like this happening. I thought the PSU had some kind of protection or even the mobo.

The only issue I ever had with this PC was that the AIO stopped working if I left the computer unused for 4+ months and obviously the mobo refused to boot without a cooler (but it had power and stayed on with the error code). This happened to me twice and the AIO started working after trying to power on a few times (about 8).

Since I lost my job and right now I'm part of a full-time coding Bootcamp, I need the computer, and sadly because of that money is an issue at the moment, but I can sell other things.

I need to determine which component is damaged (CPU, PSU, mobo, memory, or even the AIO cooler?). I need to know what is broken in order to make decisions (like selling my guitar, tv, etc.) in order to cover the costs of my mistake of not having a surge protector.

I thank you from the bottom of my heart in advance.


-CPU: Core i7 8700 (non k)
-COOLER: Corsair AIO H100i v2
-MOBO: Asus ROG Maximus X code
-RAM: 2 x 8gb Corsair vengeance RGB
-GPU: Asus Strix gtx 1080 8gb
-PSU: Corsair rm750i plus gold PSU (how could this let the surge go in?? I thought it had protection)
-STORAGE: 1 tb micron SATA SSD
-CASE: Corsair carbide
Last edited:

Vic 40

Hard to tell someone what to change. Think looking the way you tested the motherboard or psu might be at fault, looking first at the motherboard mainly because of this,
  1. Disconnected GPU, SSD. Left the PC with 1 stick of RAM, mobo, CPU, the AIO cooler, and case fans. (Not turning on).
Cooler, well the 8700 comes with a stock cooler with which you could test.

When trying to power the gpu don't just try with one cable/two connectors, but also try two pcie cables as well => one connector each (the first would imo be best).

No way you see anything on the motherboard maybe fried by the "big lightning sound"? Look at capacitors or for browned/blackened traces.