Question Boot order changing by itself

stretch9x

Commendable
Sep 23, 2019
14
1
1,515
0
Simply put, My daily driver is a 16+ year old ASUS Q400-A laptop and I often use a Ubuntu "live" on a 32gig SD card to learn the ins and outs of using the distribution before I decide to install it on a bigger card or 2nd hard drive. Now, here's the problem: I set the boot order in bios with the "live" SD card set to #1 and my windows SSD that is shown as "Windows Boot Manager" PO: (ADATA SU800) on #2. I Save and exit and reboot with the "live" SD inserted and it boots into Ubuntu with no problem. That is, until I remove the "live" SD to boot on my Windows 10 SSD and there's no issue. But, the next time I boot with the "live" SD inserted, my lap top still boots into Windows. Checked the boot order in bios and yes, the boot order has reverted. I not happy about having to make changes in my bios before needing to boot on a USB. My guess is that Windows Boot Manager is swapping the boot order as it looks for bootable devices . Yet, bios shows two of the same USB SD cards in the boot order selection list, One is labeled as UEFI, the other is not. Selecting either of these changes the way boot order works. Note: When I set the boot order for the internal DVD (don't laugh) to #1 the boot order setting persists unless the optical drive is removed. It come back in the correct order when re-inserted. Is there some easy setting in bios to stop UEFI from tossing the dice on USB boot? The bios menu is kind of sparse and has no mention of UEFI, legacy or Fastboot and instead has XHCI Pre-boot, what ever that does. Thanks
 
Simply put, My daily driver is a 16+ year old ASUS Q400-A laptop and I often use a Ubuntu "live" on a 32gig SD card to learn the ins and outs of using the distribution before I decide to install it on a bigger card or 2nd hard drive. Now, here's the problem: I set the boot order in bios with the "live" SD card set to #1 and my windows SSD that is shown as "Windows Boot Manager" PO: (ADATA SU800) on #2. I Save and exit and reboot with the "live" SD inserted and it boots into Ubuntu with no problem. That is, until I remove the "live" SD to boot on my Windows 10 SSD and there's no issue. But, the next time I boot with the "live" SD inserted, my lap top still boots into Windows. Checked the boot order in bios and yes, the boot order has reverted. I not happy about having to make changes in my bios before needing to boot on a USB. My guess is that Windows Boot Manager is swapping the boot order as it looks for bootable devices . Yet, bios shows two of the same USB SD cards in the boot order selection list, One is labeled as UEFI, the other is not. Selecting either of these changes the way boot order works. Note: When I set the boot order for the internal DVD (don't laugh) to #1 the boot order setting persists unless the optical drive is removed. It come back in the correct order when re-inserted. Is there some easy setting in bios to stop UEFI from tossing the dice on USB boot? The bios menu is kind of sparse and has no mention of UEFI, legacy or Fastboot and instead has XHCI Pre-boot, what ever that does. Thanks
Always disconnect or disable other drive(s) when installing another OS as more than often it combines BOOT sectors on first installation.
 

ASK THE COMMUNITY

TRENDING THREADS