Question boot-up stuck on asrock logo

Feb 8, 2020
2
0
10
0
Hey everyone

I've had my computer for about 2-3 weeks now, i was adjusting some fan settings in the bios, and when i went to save and restart the boot-up got stuck on the asrock logo, and not doing anything anymore.
In detail: I press the power button, the system boot after a sec of checking, fans spin, the post-message saying press f2 etc.. for bios shows up, then it proceeds to the asrock logo with the loading circle spinning, and stays just there.

Here's what I've tried:

CMOS Reset (no avail)
Reseating RAM
Clean reinstall of windows
Reseating everything from gpu to ram (not the processor, i believe that's not the issue)
Update all drivers (obviously, but nope)

Here's what I've found:

When putting my bios into ultra fast boot, it seems to skip the asrock logo and i get into my windows easily, sometimes the asrock logo gets stucka gain, but pressing the reset button allows me to get into windows again, this leads me to be lieve it's a software issue rather than a hardware issue? I believed there might be an issue with my ssd but then i wouldnt be able to get into it on ultra fast boot for example.

This isn't a permanent solution for me however and i was hoping any of you could help me, at this point i'm just considering switching to an msi B450 Mortar, as I've seen many people have this issue with Asrock motherboards.

Specs:

Asrock B450m steel legend
Ryzen 5 3600
2x8GB hyperx fury 3200mhz
rx 5700XT phantom gaming d OC
PSU: seasonic gold GM 650w
1TB Kingston SSD NVME
case: core v21
 

ASK THE COMMUNITY

TRENDING THREADS