[SOLVED] Bought 2 new memory modules for my rig, speed is advertised as 3200 but the speed I'm getting is 2400. Thanks for the help.

Dec 28, 2021
3
0
10
0
Just built my pc about a few weeks ago and decided to get some more memory. I made sure to get the exact same one's I had purchased before. The speed the two ram sticks ran was 3200, just the two sticks. When I installed the other two sticks the memory sticks now run at 2400. I tried changing the speed in bios multiple times, didn't work. I'm stuck don't know what to do.

Memory - 4 x T-Force RGB Delta ram, 3200, CL16
Mobo - Asrock B450 Pro4
CPU - R5 2600
 

Karadjgne

Titan
Ambassador
upload picture free

1st and 2nd Gen Ryzen do Not like 4 sticks at all, it messes with fclock sync if the ram speeds are too fast. 2 sticks is perfect, used in slots A2/B2, as those are the Primary slots, with A2 being superior. The other 2 slots are secondary and often will not allow speeds too far over the cpus memory controller default speed. 3000MHz is an oddball speed, some boards do not have the ability to use it, so generally 2933MHz is the next stable step down from 3200MHz.
 

ASK THE COMMUNITY