Question Bought a pre-built but it won't even get to BIOS, not sure what to do here

Oct 19, 2021
1
0
10
0
CPU: Ryzen 9 5900X
GPU: RTX 3080
Motherboard: Asus TUF gaming X570-plus (wi-fi)

Currently what I'm seeing:
  • When the psu switch is turned on, a small rgb on the motherboard cycles around
  • When the power button is pressed, the DRAM light comes on, then CPU, then VGA, but it gets stuck at the white VGA light. Case power light is on too.
  • When the power button is pressed but the graphics card is removed, both the VGA and Boot lights come on at the same time (??)
  • No beeps whatsoever
  • Pressing the power button again turns the fans and leds back off (except the small one on the motherboard).
-If I plug in a usb device like mouse/keyboard, it gets power for a split second before disconnecting.

Things I've tried:
  • Re-seated the big power cable to the motherboard (the 8-pin one at the top is too tight to remove, but it is plugged in)
  • Removed the SSD and wifi antennas
  • Try with only one stick of ram in the slot furthest from the CPU (tried with two different sticks)
  • Re-seated the PCI power to the graphics card and also the entire card
  • Both HDMI and DisplayPort from the GPU itself
  • Resetting the CMOS (pretty much between every step)
I haven't been able to try the other PCI slot because the PSU power cables it came with aren't really long enough.

Any help or suggestions are super appreciated ;-;
 
Bought a pre-built but it won't even get to BIOS, not sure what to do here
contact customer support and return it.

before getting much more into troubleshooting you need to understand that if you have caused any noticeable damage even like scratches to a devices finish or anything noticeable in any way you will very likely void your warranty and they will state that you damaged the product.
then you will have to pay to get the product shipped back and could be charged for a non-existant repair service just because they opened it up and looked at it.
 

ASK THE COMMUNITY

TRENDING THREADS