Question Bought a used Gigabyte Rx 580 gaming 8g but no display

The_assasin141

Honorable
Feb 24, 2016
76
0
10,630
0
So I just bought this used gpu for a great deal the seller told me that it was working fine till a day game and the gpu stopped giving a display.....
The fans and leds are working fine so far but no display
The gpu is not showing in windows device manager while using my old 750 ti as a display adapter
I tried different pcie slots no joy
I turned on my pc without the pcie connector the leds were still on
I went to bios and disabled integrated graphics and set boot option to csm instead of uefi
I am unable to reflash the gpu since it is not being detected.
I updated my motherboard's bios
Tried with one ram stick
Tired installing amd drivers they failed because no gpu was detected

I tried all the above if anyone had the same issues please share and help will be much appreciated guys.

My specs:
i5-10400F
16 gb ram (8x2)
Cougar gx-s 650 watts gold-rated (it is a quality build psu and had good reviews by johnnyguru and etc....)
2 HDDs
1 Sata ssd
 
May 10, 2020
104
9
165
26
I would recommend reseeding the GPU into the motherboard. Remove the power cables and it from the PCIe slot. Then reinsert the GPU into the PCIe slot and reinsert the power cables.
 

carocuore

Proper
Jan 24, 2021
208
60
170
2
hm, sounds like a dead mining card

it was probably on its last legs and that's why the guy decided to sell it, was it cheap? like suspiciously cheap? if so then my theory is most likely valid and the card is fried
 

ASK THE COMMUNITY

TRENDING THREADS