Question Bought extra RAM sticks and got message "it looks like windows did not load correctly

Jonathan13054

Reputable
Mar 13, 2019
2
0
4,510
0
I just bought two new ram sticks DDR4 3200 MHz (2 x 8 GB) and installed them into my two remaining empty ram slots, upon starting my PC I encountered the windows error message "It looks like windows did not load correctly". After restarting and rebooting I was still met with the same message. I then took out the new ram sticks and the PC started (was met with the same message but was able to load after a self repair)

Ram sticks are Corsair vengeance RGB pro and the new sticks are Cossari vengeance RGB Pro SL
MB: TUF Gaming X570-Plus
 

Darkbreeze

Retired Mod
Which slots are each set installed in? Are both of the RGB Pro sticks in slots 2 and 4 (Over from CPU socket, 1, 2, 3, 4, with 4 being closest to the edge of the motherboard) or in slots 1 and 3, and the RGB Pro SL sticks in the remaining two slots, so that the sticks from the same kit are in ALTERNATING slots, not next to each other?

If they are, then I'd try doing a hard reset of the BIOS, WITH all four DIMMs installed. And if that doesn't work, I'd recommend you read the section in my guide titled "The odd man out (Or mixed memory)" located here, and then assume that's your problem.


You can of course, as outlined in my guide, trying bumping the memory voltages in very gradual degrees to see if that helps to stabilize things. Most kits are ONLY guaranteed to work at their advertised voltage if there are only one or two DIMMs installed. With four DIMMs, advanced configuration of timings or voltages might be necessary, especially when all four DIMMs did not come together in one kit.
 

ASK THE COMMUNITY

TRENDING THREADS