Question Bought what seemed to be a better cpu but now FPS in games has dropped by around 50 fps, help

Fumarokuu

Prominent
Aug 17, 2019
15
0
510
0
I recently bought a new motherboard and another cpu...

Old: i7 2600
New: i7 3770k

As far as I could tell this is a better cpu overall. (bought it used but a new motherboard to go along with it) --- https://www.amazon.com/gp/product/B07RWZGDB5/ref=ppx_yo_dt_b_asin_title_o09_s00?ie=UTF8&psc=1
But ever since I've had it my performance in games has been terrible. It's a bit odd because The fps seems to jump all over
and cant seem to stay in one place like before.

An example is with Black ops cold war, before it would run at 60-70 on low-med settings, the frames were consistent.
But now it stays around 20-30fps and jumps to 70 fps for maybe around 30 seconds and sometimes goes below 20 fps.

I dont have other programs running other than discord sometimes.

My gpu is 1060 3gb
240gb SSD
8GB ram (it used to be 16 gb but the new motherboard didnt have room for my other two 4gb sticks)

Is this a ram issue? Because I'm using half the amount of ram. Nothing else in my pc seems off. Been updating drivers regularly.
If you could help out we'd appreciate it greatly. Thanks
 

M.AGamer

Commendable
Feb 19, 2019
378
33
1,720
4
I recently bought a new motherboard and another cpu...

Old: i7 2600
New: i7 3770k

As far as I could tell this is a better cpu overall. (bought it used but a new motherboard to go along with it) --- https://www.amazon.com/gp/product/B07RWZGDB5/ref=ppx_yo_dt_b_asin_title_o09_s00?ie=UTF8&psc=1
But ever since I've had it my performance in games has been terrible. It's a bit odd because The fps seems to jump all over
and cant seem to stay in one place like before.

An example is with Black ops cold war, before it would run at 60-70 on low-med settings, the frames were consistent.
But now it stays around 20-30fps and jumps to 70 fps for maybe around 30 seconds and sometimes goes below 20 fps.

I dont have other programs running other than discord sometimes.

My gpu is 1060 3gb
240gb SSD
8GB ram (it used to be 16 gb but the new motherboard didnt have room for my other two 4gb sticks)

Is this a ram issue? Because I'm using half the amount of ram. Nothing else in my pc seems off. Been updating drivers regularly.
If you could help out we'd appreciate it greatly. Thanks
Well like the guy above said we need you to monitor your system temps.I recommend Msi afterburner
We need the following:
Cpu temps
Gpu temps and Gpu usage
Ram usage
 

Fumarokuu

Prominent
Aug 17, 2019
15
0
510
0
Got it fixed! Just downloaded msi afterburner and got some footage, at first the live stats seemed fine so I just took the pictures of some moments in game to show you.
Then later I noticed the picture was off. The cpu temps were at 100c and upper 90s. So I knew that had to be the problem.
I remembered then the cpu fan was small and cheap and we had struggled to install it. So I borrowed a bigger cpu fan with a large heat sink and now my cpu temps are in the 60s in game.

The problem seems to have gone away now. Thank you guys again for helping.
 

Fumarokuu

Prominent
Aug 17, 2019
15
0
510
0
Hi, thanks for responding. Yeah I had older hdds and threw those away too and so I installed a new windows 10 onto the system. With ssd
 

ASK THE COMMUNITY

TRENDING THREADS