Question Brand new 3070ti extremely choppy and low frames than shown

Jan 9, 2021
5
1
15
0
I've researched big games and their benchmarks with this gpu and battlefield 2042 with ultra settings was showing 70-80 frames and I cant get 30 frames of low settings. I am so disappointed and frustrated. if anyone knows wwhat could be the problem I need the help.PC specs I have wiped my old drivers and installed the latest nvidia one so far and no help. even games like csgo stutters.
Specs

OS: Windows 10 pro 64 bit
CPU: Intel I9 9900K 3.60ghz
RAM: 16GB
Motherboard: ASROCK Z390 Phantom Gaming 9
Graphics: 4095MB NVIDIA GeForce RTX 3070 Ti (EVGA)
Storage
931GB Samsung SSD 980 1TB (Unknown (SSD))
1863GB Samsung SSD 870 EVO 2TB (SATA (SSD))
UserBenchmarks: Game 154%, Desk 95%, Work 152%
CPU: Intel Core i9-9900K - 95.1%
GPU: Nvidia RTX 3070-Ti - 169.5%
SSD: Samsung 980 NVMe PCIe M.2 1TB - 169.2%
SSD: Samsung 870 EVO 2TB - 75.1%
RAM: G.SKILL F4 DDR4 3200 C16 1x16GB - 36.5%
MBD: Asrock Z390 Phantom Gaming 9
benchmark links
 
Last edited:

boju

Titan
Ambassador
Thermals seem fine but your ram is running at 2133. Try enable xmp in bios and see if that makes any difference.

Benchmarks sites will detail test system and configuration, never assume just because gpu is same that results should be also. Your system is lacking ram speed and dual channel which bench sites will be we running.
 
Reactions: Noctur
Jan 9, 2021
5
1
15
0
Thermals seem fine but your ram is running at 2133. Try enable xmp in bios and see if that makes any difference.

Benchmarks sites will detail test system and configuration, never assume just because gpu is same that results should be also. Your system is lacking ram speed and dual channel which bench sites will be we running.
forgot to update but one of my ram sticks were not fully in and i have fixed the ram issue and i am now preforming more benchmjarks i have enabled XMP and will go back into checking my FPS in a graphical game, ram speeds have increased alot I will get back to you on how games run
 
Reactions: boju
Jan 9, 2021
5
1
15
0
Thermals seem fine but your ram is running at 2133. Try enable xmp in bios and see if that makes any difference.

Benchmarks sites will detail test system and configuration, never assume just because gpu is same that results should be also. Your system is lacking ram speed and dual channel which bench sites will be we running.
I am getting frames shown on videos and everything now thank you guys so much I am so relieved. always down on luck with computers it seems but i am so ecstatic now thank you sir
 

boju

Titan
Ambassador
Yeah no worries.

Can adjust power plans for cpu/gpu which you're probably aware of.

NvidiaCP (get Nvidia control panel from Ms store) prefer maximum performance setting in manage 3d settings. Not much difference between max and optimal when games fully use the graphics card but when playing not so intensive game then max prevents gpu from falling asleep.

Same deal with cpu, can set high performance plan or balanced. Balanced will downclock cpu while doing nothing which is probably preferred. Making sure cpu doesn't fall asleep in balanced plan in non demanding games is you can adjust plan further in advanced setting with minimum processor state to 10% instead of default 5%. Little differences can sometimes make a big difference depending on game.

Other things i change in power plan advanced window is never sleep, never turn off display and never turn off storage. Type never in field for setting you want off. I do this for both balanced and performance plan. Change plan when i feel like it. Type in search bar power plan, probably don't need to type it all before Windows suggests what you want.

I also turn off user account control. Never liked the thought of it since Vista and i just worry it'll interfere with game/driver installations. Default strength level shouldn't bother anyone really but it is a setting that can prevent things done to core of the system. Im not a pirate and don't visit malicious sites so im cool with it off.

If you're on Win10 pro, can disable Cortana easily enough in it's settings. Home edition requires registry edit, there are youtube vids showing how. Not really an issue, especially with your cpu, but taxed resource nonetheless.

Don't install utilities from motherboard manufacturer, they are bloatware, usually unstable and cause various performance issues. Asus armory crate for example, bad and high idle usage for no reason. Never user driver booster, like auto driver update programs etc, always get drivers from manufacturer when applicable. Yes drivers are fine just avoid utilities that are meant for convenience but wreck havoc. Utilities like Coretemp (cpu temps), Cpuz, Gpuz, Msi Afterburner are all good and handy to have, place icons in task bar :)

Lastly for now

If you're happy with performance, you can disable automatic device driver updates. Prevents Windows from installing any updates for hardware without you knowing. It has caused people grief.

 
Last edited:

ASK THE COMMUNITY