Question Brand new build, display not working

Jun 22, 2021
3
0
10
0
I'm building 2 builds for work and one works the other doesn't. All the components are the same identically except for the cpu.

Specs:

Mobo- AsRock B450 Pro4
PSU-EVGA 500w 80 plus certified power supply
RAM- Corsair Vengeance DDR4 2x8, 16GB at 3200MHz
Storage-WD Green 2.5" SSD 1TB
GPU- Zotac GT 710
CPU-Ryzen 7 3700x 8 core processor. The second one is Ryzen 5 5600x 6 core processor.

I got the Ryzen 7 system up and running. When I put the Ryzen 5 system together and tried to boot, there was no display. I figured it was ram or gpu. Reseated ram and gpu. no change.

I swapped the gpus in the system to see if one was faulty and that wasnt the case.

I figured that maybe drivers was an issue, so I swapped the drives, installed windows and installed the drivers and still no luck.

I double checked multiple sites to ensure that the parts are all compatible with my build and it all checks out.

I've read maybe it could be the bios update that could need an update. The ryzen 7 system is p5.56 and the ryzen 5 is p3.30. I am unsure how the bios updates work seeing as after many pc builds that I've done and have never had any experience with that.

I'd really appreciate all the help I can get!
 
I'm building 2 builds for work and one works the other doesn't. All the components are the same identically except for the cpu.

Specs:

Mobo- AsRock B450 Pro4
PSU-EVGA 500w 80 plus certified power supply
RAM- Corsair Vengeance DDR4 2x8, 16GB at 3200MHz
Storage-WD Green 2.5" SSD 1TB
GPU- Zotac GT 710
CPU-Ryzen 7 3700x 8 core processor. The second one is Ryzen 5 5600x 6 core processor.

I got the Ryzen 7 system up and running. When I put the Ryzen 5 system together and tried to boot, there was no display. I figured it was ram or gpu. Reseated ram and gpu. no change.

I swapped the gpus in the system to see if one was faulty and that wasnt the case.

I figured that maybe drivers was an issue, so I swapped the drives, installed windows and installed the drivers and still no luck.

I double checked multiple sites to ensure that the parts are all compatible with my build and it all checks out.

I've read maybe it could be the bios update that could need an update. The ryzen 7 system is p5.56 and the ryzen 5 is p3.30. I am unsure how the bios updates work seeing as after many pc builds that I've done and have never had any experience with that.

I'd really appreciate all the help I can get!
Yes, you definitively need BIOS update for 5000 series Ryzen.
For BIOS itself look at Asrock site and to for upgrade/update procedure look in MB manual and follow instructions EXACTLY.
https://www.asrock.com/mb/AMD/B450 Pro4/index.us.asp#BIOS (Get latest one)
 
Reactions: kurdtnz

ASK THE COMMUNITY