[SOLVED] Brand new build just turned on and no signal from Computer to monitor

Apr 29, 2020
5
0
10
0
I am sorry if this was asked and answered as I have been searching online all day. It has been a long time since my last build and thought it was time for a new computer. I purchased the following parts and proceeded to put it together . After some , multiple tries, I thought I had it built. I turned it on fans spin, , light on front fans and memory sticks come on as well as the rgb on the board. I do not hear any beeps , not sure if I missed the case speaker or if it even has one as I did not recall seeing one or finding one when I went back in to look.

I do not have a separate graphics / video card installed but was just connecting to the on board video from the MB. I tried the HDMI as well as the DP port. I get no signal on the monitor when I turn it on , then monitor goes to sleep mode.

The set up is as follows.

ASUS AM4 TUF Gaming X570-Plus ATX
AMD Ryzen 5 3600 6-Core, 12-Thread Unlocked Desktop Processor
Thermaltake V250 Motherboard Sync ARGB ATX Mid-Tower
G.SKILL TridentZ RGB Series 32GB (2 x 16GB) DDR4 3200Mhz DIMM CAS
16 F4-3200C16D-32GTZR
ASUS ROG Strix ROG-STRIX-550G 550W ATX12V
WD Blue SN550 1TB NVMe Internal SSD - Gen3 x4 PCIe 8Gb/s, M.2 2280,


I connected the 20 pin into MB from the PSU and the 2-4 pin (in teh 8 pin socket) I also tried removing the 2-4 pin , and also tried installing just 4 pin into the pin set up as well all with no luck.

If you need or want pics I will take and upload .

Thanks
Brian
 
Apr 29, 2020
5
0
10
0
Forgot to add, I haven even tried to install windows 10 yet or any driver updates for the Mobo as I cannot see anything on the monitor.
 
Apr 29, 2020
5
0
10
0
Thank you boju
That was going to be my next try, I didn't want to spend $70 on a cheap one just to try it and regret not getting a half decent one.
Any recommendations in the $150 range ? I am not a gamer (yet )

Brian
 
Apr 29, 2020
5
0
10
0
You're welcome and good luck

Just to follow up , I purchased the
SAPPHIRE PULSE Radeon RX 570 DirectX 12 11266-66-20G 8GB 256-Bit GDDR5 PCI Express 3.0 CrossFireX Support Video Card[ and it is working .

Thank you again Boju for the help the issue is resolved.

Have a great day

Brian
 

ASK THE COMMUNITY

TRENDING THREADS