[SOLVED] Brand new desktop build

Oct 2, 2019
2
0
10
0
So I just built a new desktop. Had some minor issues with display but I solved them. I loaded windows 10, changed all my setting, and had everything working perfectly. I turn the computer off, install my second ram card, and close the case up. Now my computer doesn’t work at all. I took it all apart. I tried plugging in just the mobo or just the gpu, but nothing light up, spins, or beeps. Did I fry my mobo? Did I blow up my power supply? Is something shorting that I haven’t thought of? This is extremely frustrating. Keep in mind everything was brand new as of yesterday. Any ideas would be very welcome.
 

hang-the-9

Titan
Moderator
If you remove that second RAM stick does it boot? If there is no sign of life after you turn on the power you may have bumped a cable to the motherboard. Did you go over the setup and check the case connections to the motherboard and all the power connections? Can also try to power the system by shorting out the power pins, that will bypass the case power button.
 

hang-the-9

Titan
Moderator
If you remove that second RAM stick does it boot? If there is no sign of life after you turn on the power you may have bumped a cable to the motherboard. Did you go over the setup and check the case connections to the motherboard and all the power connections? Can also try to power the system by shorting out the power pins, that will bypass the case power button.
 
Oct 2, 2019
2
0
10
0
I did try to take out the ram and try again. I unplugged everything and plugged it all back in. If the power button worked the first time is there any reason why it wouldn't work now?
 

hang-the-9

Titan
Moderator
I did try to take out the ram and try again. I unplugged everything and plugged it all back in. If the power button worked the first time is there any reason why it wouldn't work now?
No way to know from over the internet why it's not working, all we can go by is that it worked, then you opened the case to install something then it stopped working. In my experience that means something got unplugged or hit/shifted/broken when you opened it the second time.
 

ASK THE COMMUNITY

TRENDING THREADS