Brand New Nvidia geforce gtx 1060 armor showing black screen with "B2" in the corner

Jan 17, 2019
3
0
10
0
I just bought a new gtx 1060 but when i tried to boot up the pc with the new card, it would just show a black screen with "B2" written down in the right hand corner. Windows would open after about 5-7 minutes of waiting, but when i logged in, my screen would be locked to 1024 x 768 resolution. When i tried to chance it my screen glitched out and would return to 1024 x 768 after about one minute.

My motherboard is an MSI Z77a-G43
My power supply is an Silver power sp-ss850
 

RobCrezz

Titan
Herald
Update your motherboards bios to the newest version.

Once thats all done, see if its still slow to get to windows.

Then, youll need to install the drivers from nvidia.com so you can get the correct resolution etc.
 
Jan 17, 2019
3
0
10
0


I have tried to update the BIOS through m-flash, but the whole thing freezes as soon as i try.
 
Jan 17, 2019
3
0
10
0


Thanks for the suggestion, but i cant find anything on how to do that.
 

Shock34

Reputable
Nov 1, 2015
124
0
4,710
9
Reset the CMOS of the BIOS to default to original settings. It's fairly easy and may solve your issue.
1. Turn off the PC from the PSU AND the socket. Press the turn on button a few times to remove any electricity from the system.
2. Remove the flat battery from the front of your motherboard (usually located near the main PCIe x16 lane, under your GPU)
3. Press the power button once more (while the socket and PSU are still off)
4. Put the battery back in, making sure your hear a click to prove it's secure.
5. Reboot the computer straight into the BIOS. The CMOS has been reset and the BIOS is at its default settings. You can go from here.

If the BIOS still crashes, you may have a faulty motherboard. Consider an RMA.

best of luck! :)
 

Similar threads


ASK THE COMMUNITY