Question Brand new PSU fan stuck at 100% speed!?

zac9500

Prominent
Jul 17, 2019
10
1
515
0
Hi all,

I've just picked up a BeQuiet! Dark Power Pro 11 1000w Platinum PSU. I've built my PC, it's all working fine, except I noticed one fan was always really loud.

I set all fans to 500rpm in the BIOS and it was still there, checked again and it's my PSU fan. It's running at 100% speed constantly even when the PC is idle and I can't work out any way to slow it down or stop it.

Does anyone know if this indicates a broken unit or whether I can change this? It's very loud and annoying for a "silent" system!

Thanks
 

zac9500

Prominent
Jul 17, 2019
10
1
515
0
The fan isn't auto in that model from what I remember so it sounds like you have a defective unit or someone replaced the fan with a higher speed one.
Ahh crap. Likely a defective unit I think as the unit was brand new, and the fan inside is the factory Silent Wings 3... :( Thanks
 
Hi all,

I've just picked up a BeQuiet! Dark Power Pro 11 1000w Platinum PSU. I've built my PC, it's all working fine, except I noticed one fan was always really loud.

I set all fans to 500rpm in the BIOS and it was still there, checked again and it's my PSU fan. It's running at 100% speed constantly even when the PC is idle and I can't work out any way to slow it down or stop it.

Does anyone know if this indicates a broken unit or whether I can change this? It's very loud and annoying for a "silent" system!

Thanks
How much RGB do you have in your system? Fans? Lighting strips? etc.?
 

ASK THE COMMUNITY

TRENDING THREADS