Question Brand new RX 5700 XT crashing games (Event viewer logs included)

Oct 10, 2019
8
0
10
0
Just bought RX 5700 XT. Games run as they should until they just crash to desktop. Games tried: Witcher3, Forza Horizon4, Red Dead Redemption 2.

Windows Event Viewer would always blame the RadeonSoftware.Exe for the crash. The crash would always be "double". I.e Radeonsoftware + the game i am running. In the Figure below you can see Radeon crashign and 4 seconds later RDR2.exe crash.



After reading a ton of forum posts, I found out I can actually only install the driver and not the Adrenaline software. (I mean, if ther is no application causing error, there will be no error...) I did that but the error still occurs. This time, whenever games crash I get this:


No critical errors now, but everytime a game crash, this 141 error occurs. (It literally happens every single time a game crash. 17 times today, I have prints of all the occurances) I don't even know if this warning has anything to do with the crashing itself, I only found out there is something like event viewer yesterday.. I googled all I can about this screen, but I dont know much about pcs.
I previously had Rx480 8GB Saphhire OC+ and it worked perfectly. No issues. Since I upgraded to 5700xt I cant run any games for more than 2 hours. If I put back the 480 and put the same graphics details as with the 5700xt the games run fine for hours. Obviously frames are much much lower, but no crashing occurs.

My spec

Ryzen 5 2600x CPU
RX5700xt GPU
2x8GB Corsair Vengenace 3000MHZ RAM
B470 Gaming + Mobo
SAmsung Evo 500 GB SSD
Aeorocool Integrator Mod Xt750W PSU
Windows 10 (all up to date)


Additionally:

1. FurMark/Heaven Superposition/3DMark/OCCT/MSI Kombustor/Userbenchmark all show great scores for my card, no trouble, no artifacts.
2 Memtes86 showed 0 errors
  1. Prime95 ran for 10 hours, all workers executed jobs
  2. hwinfo shows 12V rail at 11.884 (well within the limit from what I read)
  3. DDu all drivers in safe mode. Installed Drivers with and without Adrenalin. Went back as far as 19.2.1 Drivers.

So finally my question: What can I do? Perhaps the card I bought arrived damaged?
 

ASK THE COMMUNITY

TRENDING THREADS