Question brand new sapphire rx 590 nitro oc doing problems

Feb 12, 2019
18
2
15
0
connected it after cleaning drivers with DDU.
installed latest drivers from amd , tried earlier drivers too
problem is small moving green dots over the screen, sometime disappear. only seen on black\dark screen
in safe mode and\or before drivers installed this problem was not there
with the previous basic gpu - no problem
tried both pci e x16 slots - same problem
tried used gtx 1060 on this system and sometimes this problem happened - display driver stopped responding and has recovered

its connected with new dvi d cable

lg monitor full hd with vga +dvi d

gigabyte udr3 ga x58
psu 650w
2x4 gb in triple channel
xeon w3690

dont know if to go to the store and ask them to check it or is it my system

how can i troubleshoot this?
 
Last edited:

dotas1

Reputable
Dec 5, 2015
1,239
78
5,790
197
What is the exact make and model of your PSU?
The card works before drivers because the drivers make the card run at advertised speeds.

Generally, artifacts, lines, discoloration are signs of a dying/faulty GPU. You should RMA it to make sure that you won't have future problems.
 
Feb 12, 2019
18
2
15
0
What is the exact make and model of your PSU?
The card works before drivers because the drivers make the card run at advertised speeds.

Generally, artifacts, lines, discoloration are signs of a dying/faulty GPU. You should RMA it to make sure that you won't have future problems.
THANKS FOR THE RESPONSE

Corsair 650W 80+ Gold TX650M /or bronze, i forgot.
its just brand new, so i tend to blame MY system. i suspect my mobo
but i guess ill go RMA it
 

atljsf

Honorable
BANNED
psu has nothing to do there, what you describe is a problem with the motherboard, if is old, rma only apply if under warranty

if you can try a clean windows install and then try again, without overclocking both cpu or gpu, then apply overclock s only on the gpu, to discard things before rma or replace parts, is the safest thing to do
 
Feb 12, 2019
18
2
15
0
psu has nothing to do there, what you describe is a problem with the motherboard, if is old, rma only apply if under warranty

if you can try a clean windows install and then try again, without overclocking both cpu or gpu, then apply overclock s only on the gpu, to discard things before rma or replace parts, is the safest thing to do
the gpu is overclock edition (at factory settings) you think it may do problems? maybe should i replace to regular edition?

i have a feeling that its indeed my motherboard

i thought about clean install windows 7 cause i have the cd and all. but maybe its better to install win 10?
what you say?
 

atljsf

Honorable
BANNED
i know nitros come preoverclocked, specially this 590, that basically should not be overclocked by you, because it was already overclocked by amd and sapphire

so if you did any overclock over it, disable those overclocks, i was talking more about the cpu

but as you mention, motherboard and ram are suspicious if you had two gpus and could replicate the error with both, for me that rules out the gpu inmediatelly a the source of the problem

as i mentioned, disable any ram or cpu overclock, reinstall windows if you can, then try again, if these green dots reapear, to me that is motherboard with problems and should be or replaced or rma/warranty, but wouldn't harm to try with a different ram modules to discard them as possible sources of the problem

about windows, this year windows 7 becomes unsupported by microsoft, the oldest os one should use daily is windows 8, but i wouldn't install anything other than windows 10

if you already have the windows 7 license, use it to install windows 10, it might work so you can keep using the same windows 7 license
 
Reactions: ben-z
Feb 12, 2019
18
2
15
0
i know nitros come preoverclocked, specially this 590, that basically should not be overclocked by you, because it was already overclocked by amd and sapphire

so if you did any overclock over it, disable those overclocks, i was talking more about the cpu

but as you mention, motherboard and ram are suspicious if you had two gpus and could replicate the error with both, for me that rules out the gpu inmediatelly a the source of the problem

as i mentioned, disable any ram or cpu overclock, reinstall windows if you can, then try again, if these green dots reapear, to me that is motherboard with problems and should be or replaced or rma/warranty, but wouldn't harm to try with a different ram modules to discard them as possible sources of the problem

about windows, this year windows 7 becomes unsupported by microsoft, the oldest os one should use daily is windows 8, but i wouldn't install anything other than windows 10

if you already have the windows 7 license, use it to install windows 10, it might work so you can keep using the same windows 7 license
ok first ill try to clean install win 10
so when win 10 asks for key just put the win 7 key? guess i gonna use this media tool on usb

and my guess that its my mobo, so can i still find new motherboards for my xeon? like 1366 socket? or will i need to replace the cpu with the mobo? or to buy used?
 

atljsf

Honorable
BANNED
yes, that is what i do, install the same version, if you have win 7 pro, install win 10 pro, always 64 bit versions, don't forget that

if the windows is 7 is home, install windows 10 home

it should work, that is how i do it here

about the motherboard, is a very old socket, you will find second hand motherboards in sites like ebay at high costs, nothing new

there are new motherboards but all of them come from aliexpress, huanan like this one

https://es.aliexpress.com/item/33026618487.html?spm=a2g0o.productlist.0.0.60c93fce8OwZ4j&algo_pvid=9efcb4be-e20f-479b-8322-0f8171d1e6fc&algo_expid=9efcb4be-e20f-479b-8322-0f8171d1e6fc-0&btsid=7da8389f-0e5e-46b5-91f0-1cc02184bf86&ws_ab_test=searchweb0_0,searchweb201602_4,searchweb201603_52

if the cpu is this old, i personally would consider a new pc, move to a ryzen r5, but that needs also ram, ddr4 and a motherboard, i like small cheap microatx motherboards, personally hav gygabyte b450m ds3h and very happy with it, very cheap and has not given me any problems
 
Last edited:
Feb 12, 2019
18
2
15
0
yes, that is what i do, install the same version, if you have win 7 pro, install win 10 pro, always 64 bit versions, don't forget that

if the windows is 7 is home, install windows 10 home

it should work, that is how i do it here

about the motherboard, is a very old socket, you will find second hand motherboards in sites like ebay at high costs, nothing new

there are new motherboards but all of them come from aliexpress, huanan like this one

https://es.aliexpress.com/item/33026618487.html?spm=a2g0o.productlist.0.0.60c93fce8OwZ4j&algo_pvid=9efcb4be-e20f-479b-8322-0f8171d1e6fc&algo_expid=9efcb4be-e20f-479b-8322-0f8171d1e6fc-0&btsid=7da8389f-0e5e-46b5-91f0-1cc02184bf86&ws_ab_test=searchweb0_0,searchweb201602_4,searchweb201603_52

if the cpu is this old, i personally would consider a new pc, move to a ryzen r5, but that needs also ram, ddr4 and a motherboard, i like small cheap microatx motherboards, personally hav gygabyte b450m ds3h and very happy with it, very cheap and has not given me any problems
well.. the problem was the dvi port or cable. anyway, bought a new monitor with ports of these days lol
 
Reactions: atljsf

ASK THE COMMUNITY

TRENDING THREADS