Question Brand new Seagate FireCuda 3.5" 2TB drive is not showing up in BIOS, Windows.

May 24, 2019
1
0
10
0
So I just bought a Firecuda on Ebay. Yeah I know, I should have never done that. But it was sealed in the box brand new with the anti static packaging and all. I got it for a good deal. Its not showing up anywhere in the BIOS or in Windows. Anyways, my specs are Gigabyte B360N Gaming Wifi ITX, i5-8600, RTX 2060, 120gb SSD with OS, 250GB M.2 Samsung Evo, WD Blue 1TB, 16GB Ram 450w PSU. So I have done all of the standard things, change the cable, Bought a brand new one and still nothing, power cables, different slots, removed every hard drive except the OS one, Cleared CMOS, updated the BIOS, contacted SeaGate, downloaded the software. I did try it on another computer and it was able to show up in windows, but as an ERROR, and it did not show any disk size or storage space for me to allocate. it was just blank. And When i went to initialize it, it gave me an an error. So I am really lost on what it could be besides the Power Supply, but it turns on and runs. you can feel it plain as day. So I am baffled on what it might be unless it is just faulty. Seagate will only give me a refurbished one. Not a new one. Which doesnt make a whole lot of sense. Anyways, I will get my money back and probably buy a new one, if the problem continues then I will be baffled by what it is. Maybe its not compatible? Everything on the bios is set correctly according to the 5 people I had help me figure it out. So I have literally tried every step i can possibly think of.
 

ASK THE COMMUNITY

TRENDING THREADS