Brand new system not displaying ASRock b450m pro4 ryzen

Feb 8, 2019
1
0
10
Hey all,

Just put together a build (see below for link) from a pc part picker guide and I am having trouble getting it to display. I started out by connecting everything and giving it a test run on my monitor, but nothing. Graphic card starts up, as well as fans and led for power button.

I moved it over to my tv, which works fine with console systems, and still nothing. I've tried removing and reinserting ram into their respective slots (a2 and b2 or 2 and 4). I've disconnected everything from the power supply, aside from the ATXPWR1 and ATXPWR12V1, no dice .

Last thing I've noticed is that the power button works for turning on the pc but not for shutting down. Reset button not working at all. Not sure if thats helpful.

I've also reset tried resetting the cmos by removing the battery and still nothing.

Reallly hoping I didn't f something up or something is bad.

Any tips on further troublesbokting this? I was thinking about getting one of those mini speakers that way I can at least hear beep codes is this worth a shot?
My build is below.

Thanks so much any advice would be appreciated !

My build ryzen 5 2600 with ASROCK b450m pro4:

https://ca.pcpartpicker.com/guide/vpYcCJ/modest-amd-gaming-build
 

ASK THE COMMUNITY

TRENDING THREADS