Bricked Sapphire 4870


Oct 6, 2010
I have a bricked 4870 that I need help restoring if possible. I would really appreciate some help with this if anyone has an idea of how to fix it.
Thanks in advance for any help given.

:cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:


Oct 6, 2010

Trusting a forum post on flashing from ATI Winflash. I tried to flash it with a bios mod I made from RBE that would increase default fan speed (was going to do it to both cards so CCC wouldn't need adjustment), but failed to save the original bios with GPU-z.

After the flash, it still remained running, but fan speeds were not changed, or controllable through CCC, and it didn't show up as being in CrossFire mode when I checked it with CPU-Z.

Read more about ATI Winflash and found out it wasn't capable of flashing these cards, so I didn't try it again.

Found out how to use atiflash with pin drive (HPUSB flash tool) because floppy wont hold newer bios+atiflash

I contacted a friend at Crazy PC and he got 3 recommended bios's from Sapphire, as they (Sapphire) would not respond to my emails asking for the default bios.

I tried all 3, and even tried others from Techpowerup bios collection that matched, or at least seemed to match my card. I used a pin drive for flashing with HPUSB and ATIFLASH.

After trying many times to re-flash it and get it working I gave up and took the card out. It was getting to the Windows screen, then the scroll would stop, or it would get past it (depending on the bios I flashed to it) then black screen, forcing a hard reboot. I have taken the card out now so I could use my computer.

I found a post about being able to fix a bricked card here and tried to contact the a message someone had responded, but the moderator/admin...whoever had closed the thread so I couldn't see your response.

If you can help me I would really appreciate it. I would upgrade with new card, but can't find another 4870 to buy, plus (and this is not your problem, its mine, but so you'll understand why I don't just upgrade) I am disabled from a bike wreck that crushed my spine and cant afford to do any upgrades now. This is the reason I am trying so desperately to save what I have.

Back to "ground zero"....can you help me?

I have two Sapphire HD 4870's, but when I ordered the second (same link as the first on NewEgg) it came in looking different than the first I ordered, even though I ordered the exact same card from NewEgg. I prolly should have RMA'd it, but ATI and Asus both said the cards would work the same and I shouldn't have any problems.

The card is as follows:

Model: Sapphire HD 4870 1GB
P/N 288-1E131-000SA
SKU is 11133-19-20R

PC configuration:

M4A79 Deluxe - bios 3402
Phenom II 3Ghz Deneb Blk
Zumax 750w PSU for system only
BoosterX 5 450w for cards
4GB DDR2 OCZ Platinum 1066mhz mem @ 5-5-5-15-26 2T (spd's)
3 Western Dig 320gb HDD's - 2 in raid 0 + 1 storage
2 Samsung Super Writemaster Lightscribe combo drives.
All drives run on SATA
1 standard floppy

Thanks for putting up with this long post, but just wanted you to have all the particulars involved, allowing you to make a better assessment of what needs to be done.

Grateful for your timely response and any help/advice you might have to offer,

Similar threads