[SOLVED] Bricked Toshiba pocket drive -- fixable ?

Feb 4, 2022
2
0
10
0
2tb drive is several years old, had formatted it with a Samsung Galaxy phone, was swappable with my HP Probook PC. Then I got a Motorola phone and tried to plug it in, it said the drive needed to be formatted again. No problem, I keep everything backed up, so I went ahead with the format, but it failed, and bricked the drive. Now the drive shows up in Disk Manager as unallocated, needs initializing, but initializing fails in both gpt and mbr, multiple attempts, "Incorrect funtion."

I've tried formatting with CMD Prompt as admin, says the drive is not write protected, "clean" returns an immediate success response, but "convert mbr / gpt" both fail in cmd prompt, I cannot create primary partition. 99.9% certain drive is not physically damaged. I'm not good with Cmd Prompt, I'm trying to Google my way through it, I'm sure there's probably things I haven't tried.

I now have a Pixel 6, it wants to format the drive, starts at 20% and then crashes my phone, it reboots on its own. I'll probably go back to a Galaxy phone, but in the meantime I'd like to get this pocket drive back up and running, kind of need it as a backup. I've had to retake ownership of drives and such before, but this one has me stumped. The drive is out of warranty and Toshiba support is less than helpful. Any suggestions?
 

ASK THE COMMUNITY