Question Broken GPU? Clocks jumping all over the place

woeissick

Distinguished
Apr 18, 2014
48
0
18,530
0
Hey guys,

I'm having a problem with what I think is my GPU. I can't play any game for longer than 5 minutes. It freezes the whole PC and I have to hard reset everytime. I run a memory & GPU test already, nothing showed any errors. Though while test stressing the GPU with FurMark I get framerates all over the place, though it didn't crash the PC. A few seconds 60, next second its 20 fps. I monitered the GPU's power, memory speed, processor clock und GPU utilization. While it was under 100% full utilization the whole time, the power, memory speed & processor clock showed looked like vital signs while I was testing. The clock speeds were jumping all over the place. Is my GPU broken? What else can I test? Can I fix it?

Thanks for any answers ahead.

i7-5820K CPU @ 3.30GHz
Gigabyte Windforce 980ti
32GB of RAM
PSU is from 2013, is a 750 Watt Seasonic X-Series Modular 80+ Gold

These are the statistics from MSI Afterburner during FurMark test.
 
Last edited:

froggy8

Respectable
Nov 23, 2019
619
52
1,970
1
Hey guys,

I'm having a problem with what I think is my GPU. I can't play any game for longer than 5 minutes. It freezes the whole PC and I have to hard reset everytime. I run a memory & GPU test already, nothing showed any errors. Though while test stressing the GPU with FurMark I get framerates all over the place, though it didn't crash the PC. A few seconds 60, next second its 20 fps. I monitered the GPU's power, memory speed, processor clock und GPU utilization. While it was under 100% full utilization the whole time, the power, memory speed & processor clock showed looked like vital signs while I was testing. The clock speeds were jumping all over the place. Is my GPU broken? What else can I test? Can I fix it?

Thanks for any answers ahead.
could you post you pc specs please?

also how old is your psu?
 

froggy8

Respectable
Nov 23, 2019
619
52
1,970
1
My specs are:
i7-5820K CPU @ 3.30GHz
Gigabyte Windforce 980ti
32GB of RAM
PSU is from 2013, is a 750 Watt Seasonic X-Series Modular 80+ Gold
depends how stressed your psu have been, they generally only last about 5 years or so. i think it would be wise to upgrade your psu since you have had it 8 years now.

have you got another psu you can try?
 

woeissick

Distinguished
Apr 18, 2014
48
0
18,530
0
I could buy one and try it within a certain amount of days and return it if it doesn't fix my issue. That would be one solution to me. I'd be good if it was only the PSU not the GPU.
This is what MSI Afterburner shows.
 

froggy8

Respectable
Nov 23, 2019
619
52
1,970
1
I could buy one and try it within a certain amount of days and return it if it doesn't fix my issue. That would be one solution to me. I'd be good if it was only the PSU not the GPU.
This is what MSI Afterburner shows.
wow.....i have just looked at your gpu and teh recommended psu is 600w. seems a very powerful gpu you have there, it could be the psu is now outdated and is not giving enough power to your power hungry gpu.

i do think you could benefit from the newer models of psu.
 

froggy8

Respectable
Nov 23, 2019
619
52
1,970
1

ASK THE COMMUNITY