Question broken GTX1050ti

Aug 23, 2019
1
0
10
0
Hello guys,

Today i received my new PC
link here

  • AMD Athlon X4 860K, 4 × 3.7 GHz (up to 4.0 GHz, 4 MB cache)
  • ASUS GeForce GTX 1050 Ti, 4GB GDDR5, DVI, HDMI, DP
  • Hard disk: 1 TB HDD, Seagate / Toshiba / WD
  • 8 GB of DDR3 RAM, 1600 MHz, Windows 10 Home
  • motherboard A68HM plus
It came with Windows 10 x64 preinstalled. ver 18362.295
No driver were found and i did proceed to install the drivers from the DVDs i received in the box.
I restarted the computer and i noticed the resolution is still low, image quality low, with shady pixels, slow response from the computer, the windows UI looks from stone age, like windows XP style.
First i check if the computer reads my card. I checked in dxdiag, device manager, even in the nvidia control panel. everything was right. I can open nVidia Game Ready and it says im up to date.
I proceed to unistall the driver with DDU. Downloaded the latest version from nvidia. Updated the windows. And i still have same problem.

The computer feels like it doesnt have a graphic card driver but every program says its there, i can even see its temperature and % usage.
I even tried different driver scanner- updater tools to see if i have something missing. Thanks
 

COLGeek

Cybernaut
Moderator
Not to add insult to injury, but you overpaid for that computer if the price on the provided link is correct.

In Control Panel/Device Manager, is the GTX 1050 ti identified correctly under Display adapters?
 

ASK THE COMMUNITY

TRENDING THREADS