Browsers freezes & connectivity issues on new build running Windows 10

Nov 14, 2018
2
0
10
0
Hello guys,
I've recently built myself a new gaming pc, it works pretty good on online games (I've tried fortnite for a few hours and played ~20 hours on rocket league) and I've had no issue when playing yet, rather a perfectly smooth experience, no lag and no freeze. But when I'm on my desktop, using web browsers (edge/firefox), or the netflix application, I often get 5-30s freezes, about every 5-10 minute, and there's a bigger problem with chrome (chrome only) which will timeout on every sites most of the time. I've tried to think about what could be the cause, I've tried running some diagnostic tools, checking hardware sensors to see if anything seemed abnormal, but I'm not really experienced at that and probably missed something. Can anyone help me please?
My configuration is:
Gigabyte GTX 1070 Ti graphics
I7-8700k processor
G.Skill Trident Z RGB DDR4 3000 C16 2x8GB ram
Asus z370-p mobo
500 gb Samsung 860 evo ssd boot drive
1tb Seagate Barracuda ST1000DM010 hdd storage
I'm on windows 10 and both updates/drivers are up to date
edit: There's no problem I know with my internet connection, worked perfectly with my previous pc. I'm on an optic fiber connection, with SFR as internet provider in france
 

Colif

Titan
Moderator
Are you running any Asus software thats meant to speed internet up in games?

Such as https://www.asus.com/au/support/FAQ/1009765/

Motherboard has LANGuard on it and its linked to Gamefirst 3 - https://rog.asus.com/articles/maximus-motherboards/what-is-rog-languard/
 
Nov 14, 2018
2
0
10
0
No, my motherboard does have languard, but I didn't install any software in order to improve performances, and my bios settings are set to default
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS