Question BSOD Constantly and during fresh install

Sep 12, 2020
1
0
10
0
So about a year ago i built this PC:

Specs:

-AMD Ryzen 3 2200G

-Asus Prime B450M-A-Patriot Viper Elite Series DDR4 8GB (2 x 4GB)

-PowerColor Red Dragon Radeon RX 570 AXRX 570 4GBD5-3DHD/OC

First thing i did was install windows. Everything went smooth for a couple of weeks, until i got my first BSOD (Memory Management). I didn't think much of it until it happened constantly, so i upgraded the BIOS to the most recent version. But it didn't work.

There wasn't really a pattern on when the BSOD appeared. So i checked for faulty memory connection, disconnected and connected it again. It really didn't work. The computer was usable for long periods of times, but whenever i restarted it i had to do it a couple of times before everything worked smoothly.

About 5 months ago i decided to try manjaro, since to me it was a Windows related problem. So i did, and the computer has been working correctly and smoothly with Manjaro Linux, not a single problem. But, if i really want the most out of my gaming experience i need windows, so i tried to log back into my windows partition. But that didn't work.

I've tried entering into safe mode, but i was unable to. From then i just wasn't able to even boot to the MBR, regular windows loading screen but BSOD afterwards (Memory Management). So i deleted the windows partition and tried to do a fresh install. I tried multiple USB drives with the WIndows Media Creation Tool (On a different laptop, windows 7, another with windows 10). But i just can't get windows installed on my PC now. It just BSOD randomly at any point of the installation process.

Just today i tried the memtest86 tool and passed the test 100% with no errors. Tried the linux memtest and the same.

Am i doing something wrong here?
 

SteveRX4

Notable
BANNED
Sep 29, 2020
1,477
135
890
19
Is your problem that your don't have a motherboard or a PSU or a drive to put your OS on?

Is your CPU listed in the CPU support list of your motherboard?
What bios level do you need for your CPU? What bios level do you have in your motherboard?

Is your ram listed in the memory suppoprt list of your mothervboard for your cpu?

Have you enabled XMP in bios?
Have you tried a cmos/bios reset?
 

Colif

Win 10 Master
Moderator
his problem is that linux works fine on the PC but he can't install windows 10 on it without it throwing errors at him.

Linux doesn't stress PC out as much as windows can. SO that could be 1 reason it works fine.

Specs:

-AMD Ryzen 3 2200G

-Asus Prime B450M-A-Patriot Viper Elite Series DDR4 8GB (2 x 4GB)

-PowerColor Red Dragon Radeon RX 570 AXRX 570 4GBD5-3DHD/OC


what other parts in PC?

what storage drives?

Any add on cards like wifi?

Memory management errors can be storage or just drivers. Given its throwing errors during install, could be the drive you are trying to use as well.

edit: notices this is a question from Sept. Hopes he has sorted it out by now, but you never know.
 

ASK THE COMMUNITY

TRENDING THREADS