Question BSOD Critial Process Died

Jan 26, 2021
1
0
10
0
Hello, I currently find myself fiddling with a problem I haven't had before. I recently swapped over from Intel to AMD and now I am unable to launch one of my favorite games. I factory reset windows and installed all necessary drivers. When launching the game my PC bluescreens and gives me the error "Critical Process Died". I am certain that the anti cheat software "GameGuard" is the cause for the BSOD which is required to play the game. I already tried many reinstalls for drivers/the game/the anti cheat software/disabling Windows Defender and more stuff which can be found on the web, without luck, sadly. With some more research I stumbled across this forum and I saw that others got the same error fixed so I am hoping that someone would be able to help me in my situation as well and tell me how to fix the issue.

Here is a download link to my last few crash reports: https://1drv.ms/u/s!Ap1WR0Jk_-MljE5s9IwXnAhODTNr?e=rPi5pg

Thanks in advance! I will try my best to be quick on replies.
 

ASK THE COMMUNITY

TRENDING THREADS