Question BSOD on Windows 10 even from USB drive - I'm at wit's end

Jan 21, 2021
5
0
10
0
Hello everyone ! :)

First time posting here and first time actually registering to an IT forum, I hope we'll get along !

This is going to be a doozy so please bare with me!

First of all, here is my build :

Motherboard : AsRock X570 Taichi
CPU : AMD Ryzen 3800X
CPU Cooler : be quiet! Dark Rock Pro 4
SSD : Samsung Pro 970 NVME M.2
RAM : GSkill Trident Z RGB 16GB 3600 MHZ CL 16
PSU : EVGA Supernova G3 750W 80 Gold+
GPU : Radeon 5700XT Powercolor Red Devil


Alright so I'll do my best to write everything I know about my case.

Around 10 days ago I decided to do my first PC build which happened without an issue. Followed a couple of tutorials, was very careful, everything was fine.
Decided to boot Windows 10 taken from the official Microsoft website from a USB drive and installed it, no worries here too.
My system ran fine for I'd say 5/6 days when all of a sudden, while I was watching Youtube, my PC shuts down with the BSOD : "System Service Exception"

I didn't pay much mind to it but silly was I to think that it was the end... From that point onward, I wouldn't be able to boot normally.
Following this first BSOD, I'd try to boot normally and sometimes I'd reach the desktop before the BSOD appears, sometimes it'd happen during the boot itself after the Windows logo appears and it even happened during while I was navigating the options to run into Safe Mode.

Here is an exhaustive list of all the BSOD I encountered :

- SYSTEM SERVICE EXCEPTION
  • System Thread Exception Not Handled
  • System Thread Exception Not Handled (NETIO.SYS)
  • driver irql not less or equal
  • KMODE_EXCEPTION_NOT_HANDLED
  • kernel security check failure
  • SYSTEM SERVICE EXCEPTION wpprecorder.sys


It got worse and worse up to the point now where I just can't do anything and I'm stuck on a boot-loop with the BSOD : chaunting me.

Naturally I searched online to find a solution to my problem but most of them advised steps I cannot perform. Kindly refer below to the troubleshooting list I did :

  1. Tried RAMS one after the other with MEMTEST = Returned 0 errors
  2. Tried to override the Windows installation with a fresh install from a USB drive correctly formatted = BSOD System Thread Exception Not Handled when I try to boot from the USB stick.
  3. Update my AsRock BIOS to its latest version 3.80 from the official AsRock website = Same result
  4. Tried various combinations of settings within the BIOS (CSM/Secure Boot disabled/enabled, trying with CSM enabled but with Legacy settings only, disabling integrated Wi-Fi, changing RAM Mhz, RAM voltage) = Same issue remains
  5. Did a Secure Erase of the NVME and seeing that it didn't change anything, did a sanitization of it = Nothing changed, still BSOD (same message)
  6. Put Ubuntu on the USB drive to check if Windows was the issue and Ubuntu booted without a problem. Tried the command sudo os-prober = Returned nothing at all after punching Enter, just went to the next line with nothing happening whatsoever which I believe means that Windows cannot be found / is corrupted.
  7. Went on tb.rg-adguard.net to grab an old version of Windows, thinking that the older drivers would be more peaceful with my PC (since at that time I thought that my PC crashed while downloading drivers in the background) = Same blue screen
  8. Tried to use Hiren's Boot CD to access a lite/safe environment of Windows to try and repair something = Same problem.
I'd like to precise one thing that may be of importance : While my build was running, I played some games (mainly Sekiro : Shadows Die Twice) on Ultra crystal clear, no problem happened. During the check of my hardware, I realised that one of the 4 pins connectors to my CPU wasn't plugged in so my CPU was powered only by a 4+4 pin. Plugging the additional 4 pins connectors didn't solve the issue either.
Maybe it was a huge mistake on my end but since my system never showed any symptoms from not being fully powered, I'm doubting that it'd be the cause of what's happening since the problem happened while I was demanding far less power from the system.

Througout my researches, I've encountered some threads where the issue was hardware related ; replacing the CPU or the motherboard did the trick which I'm reluctant to do (but that I'd do if that's what must be done)
Here are the threads links : https://forums.tomshardware.com/threads/different-blue-screen-every-time-when-booting-from-usb.3198357/page-2?view=date
AND : https://answers.microsoft.com/en-us/windows/forum/windows_10-performance-winpc/win-10-reboot-loop-of-death-system-thread/909e99b9-1163-480f-a42f-23e1f5352f86?page=2

As the title mentions, I'm at wit's end... I've been at it for 4 days now and I'm still not sure if it's hardware related or if I could somehow overwrite Windows with a fresh installation through some magic trick. Maybe Windows is buried so far deep into my system that changing the hardware is inevitable, I don't know...

I'm open to any suggestions that I may not have thought about, anything to help me, I'll gladly take it!

Thank you for your time and I hope my post was detailed enough without making you snore in the middle! :) May you have a good day or night!
 

Colif

Win 10 Master
Moderator
which bsod do you get booting from USB?

how many times did you run the ram through Memtest?
if you did step 5 before step 6, i know why its not showing anything, the drive is empty

have you tried another USB stick as it might be the drive itself causing the errors. especially if you get them when you boot off USB. When you running off USB, only 2 places data is - ram and USB.

removed any overclocks you might have?

motherboard manual - https://download.asrock.com/Manual/X570 Taichi.pdf
have you been using boot override to boot off USB? its on the save & exit tab of bios, lets you bypass boot order without changing it.
 
Last edited:
Jan 21, 2021
5
0
10
0
Hello Colif and thank you for your answer!

The BSOD I'm having when I try booting from the USB is : System Thread Exception Not Handled.

I ran Memtest once for both stick of RAM, let Memtest do the whole 13 tests 4 times to have the most accurate results but nothing showed up.

I did step 6 before step 5, apologize for that mistake. Windows seemed unpresent prior to the Secure Erase being done.

Oh, I haven't tried with another USB stick as it worked fine from the get-go and I was always thorough with the formatting of the drive before doing anything with it. I'll give it a shot.

Never applied any overclock to my system, always used it at stock, the issue happened without any OC being done.
Once the issue happened however, I changed some OC settings to see if it could do the trick byt alas it didn't.

I've used Boot Override to force the boot from the USB drive with no successful results... Tried with settings the USB as Boot Option number 1 from the BIOS, using F11 when the PC boots to choose the USB as booting device too, nothing worked.

Thanks for checking my issue :)
 

Colif

Win 10 Master
Moderator
netio.sys could have been lan drivers, but without knowing what files were running at time of the other crashes I couldn't guess what cause might be.

when you built PC, did you go to the Asrock website and make sure you had newest motherboard drivers?

you can try to run a disk scan on the USB, right click it in File explorer and choose tools/Error checking as that might fix any errors on the installer.
 
Jan 21, 2021
5
0
10
0
When I built the PC, I haven't been to the AsRock to download the latest drivers, I just built everything, let the updates happen by themselves after being connected via LAN cable and that's it.
Everything was well and good for several days so I wonder if that may be the source of the problem. If it was, it should've happened earlier, no?

I just finished running the Error check on the USB drive and no errors popped up, the drive looks well clean.

Thanks again for your time. :)
 

Colif

Win 10 Master
Moderator
its possibly 5 days later windows update might have run and updated drivers. Win 10 should have tried to get latest drivers but it only has new drivers if the makers have supplied them. some are better than others. I don't know how good Asrock are as I have never had one.

If you can get Win 10 on this time, go to http://www.asrock.com/mb/AMD/X570 Taichi/#Download and download both the AMD all in one driver and the App store. I believe you can use App store to update drivers, and apps (but you don't need the apps in most cases)
 
Jan 21, 2021
5
0
10
0
I've tried to boot one more time from the USB drive with a fresh install of the latest Windows 10 version from official Microsoft website and was greeted with the BSOD : System Thread Exception Not Handled.
I don't know if it's of any importance but I tried booting from an older version of Windows (build 1809), I was having the BSOD in really high quaity and with the latest build from Microsoft, I have it in quite a lower one.

Are you suggesting me to download the All-in-1 drivers from AMD if by chance I can get Windows to boot ? Or I can download it onto the USB and boot from the USB and the drivers update will happen ?
I'm really hoping it's the latter because I cannot acces Windows / Safe Mode at all.

Cheers :)
 

Colif

Win 10 Master
Moderator
Are you suggesting me to download the All-in-1 drivers from AMD if by chance I can get Windows to boot ?
no, i mean if you can reinstall it again.
if the nvme is blank, and its a new USB, and the ram checks out... we running out of choices with what to blame errors on.

i would run some tests in linux since it seems to work there, check out the hardware and make sure its okay. The source of the errors isn't windows itself if you can't even get it on.
 

ASK THE COMMUNITY

TRENDING THREADS