Question BSOD on Windows 10 pro on a brand new build, PC running poorly after recovery

Most_Wanted_Potato

Reputable
Jul 28, 2016
15
0
4,510
0
Hello

about 2 weeks ago I build a brand new computer with all new parts. Yesterday I got and BSOD error message: SYSTEM_SERVICE_EXCEPTION. After the reboot pc went into bios and I could not leave the bios. When I clicked save and exit pc rebooted and I was again in the bios so basically I was looping in the bios. Also my m.2 Kingston SSD was not detected, not even as an boot drive but my hard disk was detected. In the end I did the reset config so I could load into windows. I immediately ran WhoCrashed program and the program could not find any corrupted drivers. So I checked if the windows were up to date and they are. I also checked if my network driver is up to date and it is. I then opened the command prompt and ran chkdsk and the windows showed it fixed my C partition. I am noticing that my computer is running really slowly and it is kinda slugish. Also after the BSOD my network card cannot reach 100 Mbps download and 40 Mbps upload even though my laptop can easily reach 200 Mbps download and 90 Mbps upload speeds on the same cable. Also my audio cuts out and it is laggy if I run it through my FiiO usb DAC and amp ( note: the dac itself works perfectly fine on my laptop and the dac is driverless it is plug in and play). So I would really be happy if someone can help me to figure this out because at this point the only thing I could think of is to do a complete new install of windows but I really don't have time to do that right now cus I need the pc for Solidworks.

Thank you all in advance for taking your time!

My specs:
Ryzen 5 3600
MSI B550 Tomahawk MAG mobo
Gainward Phoenix RTX 3070
Corsair Vengeance 2x8 16gb 3200 MHz
Enermax Revolution D.F 650 Watt psu
Kingston A2000 500 GB m.2 ssd
Seagate barracuda 2Tb 7200 rpm 256 MB of cache
Be quiet dark rock 4 cooler
 

Most_Wanted_Potato

Reputable
Jul 28, 2016
15
0
4,510
0
did you fresh os install 2 week ago when you build this?
latest bios?
Hello

yes I bought a windows 10 pro license on kinguin and I called to microsoft support center so I could activate my license and I did a clean install with windows 10 iso image. I did not update the bios because the reputable shop build the pc for me and they also did all the settings in the bios for me and they stress tested the pc and everything worked totally fine for 2 weeks until yesterday. I also did check for any malware with eset. So how do I update the bios I have never done that before I watched some tutorials from Jayztwocents but I really don't want to f something up because my mobo doesn't have dual bios if I recall correctly in case something goes wrong.
 

Colif

Win 10 Master
Moderator
So how do I update the bios I have never done that before I watched some tutorials from Jayztwocents but I really don't want to f something up because my mobo doesn't have dual bios if I recall correctly in case something goes wrong.
MSI are nice, they have a video
https://www.msi.com/Motherboard/support/MAG-B550-TOMAHAWK

whocrashed least likely program to actually show you driver that caused error, most likely blame ntoskrnl which is what did crash but only as it does so much. Its the windows kernel. That and if i read you correctly, you did a reset before running it, and the reset would have wiped the memory of the errors.

did you check the website above after updating to make sure you had newest drivers?
 

ASK THE COMMUNITY

TRENDING THREADS