Question BSOD then no display...

Jul 5, 2020
5
0
10
0
Good evening. I should have come here sooner but have done some testing of my own and run out of ideas.

I've had my pc 2 or so years without any faults... This morning I turned on my pc and was greeted with a BSOD (irql not less or equal) and after reaching 100% my pc rebooted and ever since I have had no display...

I've unplugged the gfx card completely and haven't reinstalled it either and also hard drives for the most part (will explain later) I've been using the onboard hdmi.

I do not have a motherboard speaker so bare with me. I have tried using 1 memory stick and in different slots with different LED results.

Standby Power LED always on, DRAM led always on (in certain ram configuration), boot drive LED (always on in opposite ram configuration).

When ram stick is in the 3rd slot (I think B2 or A2) all LEDs will cycle two or three times before stopping at boot drive LED where it stays on. In this configuration the pc will power off instantly when the power button is pressed.

When ram stick is in any other configuration the pc will turn on without cycling through LEDs and only DRAM and Standby LEDs stay on. Turning off pc in the configuration requires holding the power button for 5 seconds(like normal).

I have also tried resetting CMOS with jumper and without jumper.

Asus z97 pro gamer mobo
I5 4690k
HyperX Savage DDR3 I think at 1600
Evga 650w gold or something.

Any help is much appreciated
 
Jul 5, 2020
5
0
10
0
I also tried booting without CPU power as I saw somewhere that some mobos can boot into bios with no CPU power but it starts for half a second then turns back off
 
Edit scratch that as you have reset the CMOS.

I would still install your GPU back and the RAM exactly as it was before the issues started and reboot. Double check all your cables are in properly.

What GPU do you have?
 
Jul 5, 2020
5
0
10
0
Yes I've tried the jumper and the other way to reset cmos. I've put the whole pc back together now in hope it came back on working normal this morning but didn't. Graphics card is matrix 980ti. With everything back to normal it boots up with no display with the dram LED on solid red

It seems like maybe the ram/CPU/psu/mobo is at fault but it was weird that it bsod and no display since. I thought it would just start as normal after that or at least allow me to enter bios
 
Jul 5, 2020
5
0
10
0
There's a red backlight across the left side of the board too that I haven't noticed before. It might be just lighting but I haven't noticed it before
 

ASK THE COMMUNITY