Question BSOD with new build i9 12900k - Memory_management/System_service_exception

wharris1985

Reputable
Oct 30, 2018
30
1
4,535
0
System Specs:
Corsair 7000D RGB full tower (brand new)
Asus Rog Strix Z690 A (Brand new)
Intel i9 12900k (not overclocked)
Nvidia RTX 3080
Corsair Dominator Pro 3600mghz 16x4 (64gb) (Brand new)
Corsair h150i Elite Lcd AIO (brand new)
7 Corsair ML140 RGB fans (all fans brand new)
4 Corsair SL120 RGB fans
2x Corsair Commander XL(brand new)
1 Corsair Core (brand new)
Samsung 980 Pro m.2 SSD 1TB (brand New)
CORSAIR - RMx Series RM1000x 80 PLUS Gold (Brand new)

I'm looking for suggestions to find what issue is causing BSOD. I'm frustrated because I decided to upgrade my 9900k to a 12900k and spent around 2500.00 for the parts to upgrade. After installing windows and downloading all my launcher and programs my computer gave me a BSOD with a memory_ management error. When restarting the PC it then gave me a "service_system_exception" error. At this point it kept looping and I couldn't get to the log in screen. I decided at that point to do a clean install of windows again deleting everything. It seemed to work fine for the rest of the day. The next day my kid was on the PC and it seemed to be frozen. Then it restarted and gave another "memory_management" error. When restarting it took me to the login screen and has seemed to be running fine, but it doesn't feel good knowing something is wrong. From what i've read is that it could be multiple things including RAM, which sounds like what most people point to. I've been trying to do the things i read online such as

Crystal Disk - I ran speed tests on the new M.2 to make sure the speeds were matching advertised speeds. It was running at or over what it is supposed to

I ran windows memory diagnostics and within the first 5% it said "hardware problems detected. To identify and repair these problems, you will need to contact the computer manufacturer. This scared me thinking it would be either the CPU or MOBO. But reading online that is not the case, it can still be something as simple as RAM or drivers.

I ran the windows update to make sure all drivers were up to date along with NVidia drivers for the Rtx 3080

I read that overclocking the RAM in BIOS could cause stability issues, including Enabling Xmp which i didn't have enabled. I did however go into the ram speed and manually set it in the drop down box from whatever the bios had it at, like 2333mhz to 3600mhz to match the 3600mhz on the ram. When doing this, when I went into BIO's it still showed the ram set to 2333mhz on the main screen, To see if anything would change i changed the setting to xmp1 to see if that would make a difference. When doing this it change the voltage on the ram and set the ram to 3600mhz. This also changed the ram speed on the main home screen in bios to 3600mhz. I couldn't really tell if anything made a difference.

Then I read that each package of ram are sold as paired and should be paired on the MOBO even if they are the same brand speed etc. Reason being because over time as the ram are being made they could be made with different parts as others became less available, so even though they could be ALMOST identical they sometimes won't be exact and the MOBO could be sensitive. Long story short I decided to remove the ram and figure out which 2 were pairs and positioned them into the 1-3 slots and 2-4 slots as pairs. When doing this the PC wouldn't show anything on the screen when booting. I looked at the MOBO manual and i had it correct the first time . the first pair should be slots 1-2 2nd pair slots 3-4. When doing this the PC booted up fine again.

The CPU temps and usage seem to be fine in MSI afterburner while gaming and using the PC. At times the CPU will show that its running around 4.5gz, when i don't have anything overclocked on it but the CPU has a stock speed of like 3.2ghz. I'm assuming the settings in bios allow it to increase if needed?

i've checked all like 16 of the cores to see if any drivers needed updates and it says they all have the lastest updates.

Long story short, i've been trying to figure this out with little knowledge on how to detect the main culprit correctly. I've read to check to see if ALL drivers are up to date because a faulty driver could cause the issues as well. Windows is up to date through the system and security update option.

I've also read to do a memtest86 which i see the option in bios, but i'm not sure how to run that. It also says i'll have to run a test on each individual stick of ram which takes 24 hours each. The thing is, reading about it, it says that even if it detects an error, it can mean its either the ram, motherboard, or CPU. So i don't know if that will help either. I'm hoping its something simple because I don't want to have spent all this money and have a looming issue haunting me overtime lol.

Any suggestions or help is appreciated! I'm pretty clueless with bios and i feel like when i'm in there i'm scared to mess with too much as I don't know exactly what it does.

Thanks!
 

wharris1985

Reputable
Oct 30, 2018
30
1
4,535
0
So I ran the memtest86 one each ram stick individually. One of the 4 immediately started showing cpu errors. I put a pair of the good sticks back in the mobo and fired up. Ran memory diagnostics test and no hardware errors detected. I think a faulty ram was the culprit.
 
Reactions: Why_Me
Mar 5, 2022
1
0
10
0
So I ran the memtest86 one each ram stick individually. One of the 4 immediately started showing cpu errors. I put a pair of the good sticks back in the mobo and fired up. Ran memory diagnostics test and no hardware errors detected. I think a faulty ram was the culprit.
Immediately as soon as I read your initial post a couple minutes ago, I knew it was the RAM. Corsair RAM is absolute garbage; it has a high dead on arrival rate and often does not hit rated specs (this is likely the reason it was only running at 2133MHz even after enabling higher speeds)

Stick with G.Skill or Crucial RAM in the future. Unfortunately DDR5 Crucial Ballistix will not be produced as of now (they seem to be discontinuing it) but if you can return that Corsair ram get some Ballistix DDR4 while you still can. You will not regret it.

(My account is new because I’ve only ever lurked here. I’m active in the LTT community lol)
 

ASK THE COMMUNITY

TRENDING THREADS