[SOLVED] BSOD with XMP

berg247

Prominent
Feb 4, 2021
3
0
520
1
Hello guys, Im having a problem with xmp causing random BSOD mostly on gaming.
My specs are
MOBO MSI x470 gaming plus
CPU Ryzen 7 2700x
RAM G.SKILL RIPJAWSV 16GB DDR4-3200 (F4-3200C16D-16GVKB
PSU Corsair CX650M
So when I'm enabling xmp profile 2 at 3200 MHZ I'm getting random BSOD while gaming and while browsing. I've tried memtest with both sticks and xmp enable and I got a lot of errors in test 8, after that I tried it with each stick itself and I notice that slot B2 causing the error while the A2 is passing all the tests. I'm guessing maybe faulty psu maybe, I've tried all Ram and Soc voltages and timings through DRAM calculator too but no change, also update the bios no change either.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

What is the make and model of your discrete GPU? You might want to also see which BIOS version you're on at the moment for your motherboard. You might want to make sure you've gradually worked your way to the latest BIOS version and then manually input the timings, frequency and voltages as seen on the sticker of the ram stick in BIOS.

How old is the PSU?

You're advised to run memtest on each stick of ram in each slot on the motherboard to rule out a faulty stick or slot.
 

berg247

Prominent
Feb 4, 2021
3
0
520
1
Welcome to the forums, newcomer!

What is the make and model of your discrete GPU? You might want to also see which BIOS version you're on at the moment for your motherboard. You might want to make sure you've gradually worked your way to the latest BIOS version and then manually input the timings, frequency and voltages as seen on the sticker of the ram stick in BIOS.

How old is the PSU?

You're advised to run memtest on each stick of ram in each slot on the motherboard to rule out a faulty stick or slot.

Hey!! Thanks for your reply!!
My GPU is GTX970 . I updated my bios with the latest one I tried all timings frequencies and voltages either from sticker and DRAM Calculator enough times.
My PSU is 6 years old. I really don't like Corsair PSU cause I had always problems with overclocking with this brand but I didin't have the money to change it until now which I'm gonna replace it with an EVGA 650 G2. On memtest all 4 slots with a single stick pass the test's with XMP disabled, but when I'm enable XMP only slot 4 (B2) get errors while testing each stick itself.
 

ASK THE COMMUNITY