Question BSOD

Aug 3, 2021
5
0
10
0
I have a computer with an asrock b450m/ax mobo, Ruben 5 3600 cpu, (1) 8gb stick of 2666 ddr4 and I am getting a critical process died bsod. I tried upgrading the gpu to a gtx 1660. Once I did that the computer took a very long to time start then it just restarted and I tried logging in again and it gave me the bsod critical process died. I tried tacking out the cmos battery and putting it back in, and putting the old gpu back in but it won’t stop. All the computer does now is goes to a loading screen with the asrock logo and a spinning wheel. It stays there for 10-11 minutes hits the blue screen of death and starts over again. I am thinking there’s a problem with the gpu driver but I don’t know how to boot to update the driver. Please help!
 

jay32267

Champion
I have a computer with an asrock b450m/ax mobo, Ruben 5 3600 cpu, (1) 8gb stick of 2666 ddr4 and I am getting a critical process died bsod. I tried upgrading the gpu to a gtx 1660. Once I did that the computer took a very long to time start then it just restarted and I tried logging in again and it gave me the bsod critical process died. I tried tacking out the cmos battery and putting it back in, and putting the old gpu back in but it won’t stop. All the computer does now is goes to a loading screen with the asrock logo and a spinning wheel. It stays there for 10-11 minutes hits the blue screen of death and starts over again. I am thinking there’s a problem with the gpu driver but I don’t know how to boot to update the driver. Please help!
Make model and age of PSU?
When did this start?
How long was it working before this?
What GPU was in there before the 1660?
 
Aug 3, 2021
5
0
10
0
Make model and age of PSU?
When did this start?
How long was it working before this?
What GPU was in there before the 1660?
Not sure about model and age of PSU it is an ibuypower PC
It started as soon as I put the new gpu in.
It was working for a couple of months to a year.
Graphics card before was a gt 710
 

jay32267

Champion
Here is why I am focusing on the PSU.
It is extremely common for companies like ibuypower...that build PCs.....to use the cheapest PSUs they can find.
On top of that...they tend to not give you any headroom.
The 1660 draws 100 more watts than the 710.
This is looking like "PSU" to me.
If you can get anything off the PSU label...that would help...however.....

Being it is a prebuilt...I most likely wouldn't trust that PSU with my hardware (because a cheap PSU can destroy your whole system) and i would be replacing it ANYWAY.
...but I think there is a great chance this will also solve your problem.
 
Aug 3, 2021
5
0
10
0
Here is why I am focusing on the PSU.
It is extremely common for companies like ibuypower...that build PCs.....to use the cheapest PSUs they can find.
On top of that...they tend to not give you any headroom.
The 1660 draws 100 more watts than the 710.
This is looking like "PSU" to me.
If you can get anything off the PSU label...that would help...however.....

Being it is a prebuilt...I most likely wouldn't trust that PSU with my hardware (because a cheap PSU can destroy your whole system) and i would be replacing it ANYWAY.
...but I think there is a great chance this will also solve your problem.
I just put the 710 back in and it’s still giving me the bsod
 
Aug 3, 2021
5
0
10
0
Here is why I am focusing on the PSU.
It is extremely common for companies like ibuypower...that build PCs.....to use the cheapest PSUs they can find.
On top of that...they tend to not give you any headroom.
The 1660 draws 100 more watts than the 710.
This is looking like "PSU" to me.
If you can get anything off the PSU label...that would help...however.....

Being it is a prebuilt...I most likely wouldn't trust that PSU with my hardware (because a cheap PSU can destroy your whole system) and i would be replacing it ANYWAY.
...but I think there is a great chance this will also solve your problem.
Would reinstalling windows help?
 
Aug 3, 2021
5
0
10
0
I understand getting a new PSY but why I’m i still getting bsod and going to bios with the old 710 in? If it was a problem with the power supply wouldn’t that fix it?
 

jay32267

Champion
I understand getting a new PSY but why I’m i still getting bsod and going to bios with the old 710 in? If it was a problem with the power supply wouldn’t that fix it?
Perhaps....but perhaps the new 1660 stressed the PSU.....and something happened to it.
That wouldn't be extremely surprising.

Many times....a BSOD is caused by the PSU or temps.

You could also check the CPU and GPU temps with HWInfo.

In general you want the CPU 70-75 or below and the GPU 80-85 or below.

...but the fact that you are using an ibuypower PSU....that you tried to get 100 more watts out of.....has me focusing on the PSU.

Maybe you will find.,...that it's the temps...but I'm still leaning on PSU.
 

ASK THE COMMUNITY