Bug Or Feature? AMD's Catalyst Doesn't Recognize NB Driver

Status
Not open for further replies.

omoronovo

Distinguished
Feb 2, 2010
10
0
18,510
0
Am I the only one that took note of the fact that the driver version installed was "1.3.3.7"? Maybe Microsoft and ATI/AMD were trying to tell you not to bother :p
 
G

Guest

Guest
This problem has certainly been around for years. I remember posting a question about it on the AMDGame forums.
 

youssef 2010

Distinguished
Jan 1, 2009
1,263
0
19,360
32
A very useful article.I never knew this feature existed because I never ran into any problems whatsoever with AMD's drivers.Now,

@lradunovic77:you might want to try the driver release that fried the GPUs from Nvidia or the flagship GTX295 that overheatead and didn't run some games on high resolution due to limited frame buffer(which it was designed to do).I think ATI might have some driver problems but, they never released a driver that fried GPUs(at least none that I know of).Just think of their 4670 and shut up.

@superflux: just please read the drivers release notes to know if your laptop brand is supported or not,as I ran into the same trouble with my laptop when I couldn't update my drivers and finally found out that the only drivers that will work are the ones supplied by the manufacturer of the laptop.
Sorry for the long comment.:)
 

viewwin

Distinguished
Jan 29, 2009
14
0
18,510
0
I wish my hd 5770 would just play any game with windows 7 64bit. I get an ATI driver crash every time. Google turned up tons of people with the same problems.
 

user-one

Distinguished
Dec 16, 2009
76
0
18,630
0
so what the article is saying is that if you do an express setup then the problem is solved? well, there you go glad i could point out the already availalble solution. Are you sure this site isn't part of the US Government?
 

lradunovic77

Distinguished
Dec 20, 2009
405
0
18,780
0
@yousseff 2010 obviously you don't run crossfire or tri crossfire system, only 10.4 works ok with that setup, everything else is crap. Also case Nvidia has is the only example you could put out there. Wtf you are talking about, think of their 4670?
CCC is a crap and other million people will tell you the same. ATI needs 4 months before they fix all issues with new released game. Crossfire scale is a joke compared to SLI. Latest 10.6 is horrible for BF BC2 in Crossfire setup. I can give you list and list of broken things with CCC, not to mention lack of good AA support. What a joke!
 

Bolbi

Distinguished
Jul 11, 2009
733
0
19,060
43
I have encountered the North Bridge problem (says it installs correctly but then doesn't recognize that if you run the installer again) for as long as I can remember. I'll definitely try the workaround (and update) options when I upgrade to the 10.7's in a few days.
 

Rosanjin

Distinguished
Apr 30, 2006
58
0
18,630
0
Just a thought, but I'd like to make a suggestion to the folks that complain about ATI drivers. Thoroughly check your power supply. If the PSU is not supplying the juice required by the card(s), you're going to get repeated driver error messages. Make doubly sure the +12v rail isn't drooping. This is a fairly common issue that causes a lot of misplaced blame.

Cheers, and happy computing. :)
 

domenic

Distinguished
Apr 23, 2009
69
0
18,630
0
It don't think you can classify this as a bug because the default configuration has been set this way. it would be interesting know why.
 

mtd324

Distinguished
May 20, 2009
30
0
18,530
0
[citation][nom]lradunovic77[/nom]@yousseff 2010 obviously you don't run crossfire or tri crossfire system, only 10.4 works ok with that setup, everything else is crap. Also case Nvidia has is the only example you could put out there. Wtf you are talking about, think of their 4670?CCC is a crap and other million people will tell you the same. ATI needs 4 months before they fix all issues with new released game. Crossfire scale is a joke compared to SLI. Latest 10.6 is horrible for BF BC2 in Crossfire setup. I can give you list and list of broken things with CCC, not to mention lack of good AA support. What a joke![/citation]

....BF:BC2@ runs perfect for me with latest drivers. 40-50fps @ 1600x900 Med-Hi details 4x AA. And I only have a 1GB HD4850 running on an i5-750.

One of us is the exception to the rule here....
 

Trueno07

Distinguished
Apr 15, 2009
508
0
18,990
1
Looks like a solid fix to me, other than this being a haven for Nvidia fanboys to rip up ATI... I've had no problems with 10.6 and my single Radeon 5850...
 

Sihastru

Distinguished
May 4, 2009
67
0
18,630
0
[citation][nom]cobra_comm@nder[/nom]Great article. Do you think this could be related to the infamous "Unknown Device" listed in Device Manager of every AMD/ATI system I have?[/citation]
ATi driver strikes back... again... again... again... again... still waiting for them to fix the "pixel snow" effect on 2560x1600 dual link dvi displays... 'been waitin' for about 7 years now. I hear 7 is a lucky number.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS