• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Bug


Win 10 Master
are those the details of the exe file?

Is it a steam game as it appears Steam games always show as URL but if you choose "run with" as Steam then it should work

another fix on same page (see below) is
When pressing on it windows is gonna ask, "What do you want to use to run this app?".
Press on internet browser and it's going to restore all icons/shortcuts


Win 10 Master
All go guys need to do is,
Open With the app.
Choose Internet Brower (not google or firefox its called internet browser it self)
and set it was default too!
and all should be good you can run it from it
icons should be back good
Seems it affects all URL shortcuts so this might help
You can also associate the .URL extension through the Default Apps page of Window's Settings.
Start Menu > Settings > Apps > Default Apps > Choose default apps by file type
Associating .url with Internet Browser seems to fix it.