[SOLVED] Building PC, SSD Not Detected in BIOS

Oct 19, 2019
12
0
10
0
I am building a new pc using the ASRock B450M-HDV R4.0 Motherboard. Every part of the PC is working except the SSD is not being detected in the BIOS. Since the SSD is not detected I do not have a functioning drive to install Windows 10 on.

I bought 2 SSDs, both of them work, I have tried multiple SATA cables, and have tried multiple SATA ports.

I am just trying to get one of the SSDs to show up so that I can install Windows and start using my PC. The only thing left that I can think of is downloading a specific driver or the motherboard could be broken.

If anyone could find the link for the correct drivers or has any ideas to try fixing it it would be really helpful.
 
Oct 19, 2019
12
0
10
0
What specific drives?
I'm not sure what drives it has on it or anything

It came with a DVD that says ASRock AMD series AAM4-22 Version 2.2 Driver DVD

Basically I got the motherboard, plugged in the CD that came with it, and it takes me to the BIOS

Everything on the PC works, every USB, display port, etc.

I'm not 100% sure whether the ethernet is working on it or not

I plug in the Windows installation CD, I get to the part of choosing a drive to install Windows on and it does not display any drives

Since I can't find any drives I don't have any way to install Windows
 
Oct 19, 2019
12
0
10
0
It's been like 4 or 5 years since I built my last PC so I forgot you had to connect the SATA cable from the power supply to the SSD :(

Just have to find the cord and figure out how to plug it in and then it should be working good then :)
 

USAFRet

Titan
Moderator
Mar 16, 2013
114,553
2,115
157,240
18,630
Have only ONE drive connected while you do this OS install.

 

ASK THE COMMUNITY

TRENDING THREADS