Question Built a brand new pc but used a CX850M Corsair PSU, samsung 850evo and seagate hard drive. And still having the same issues.

Apr 18, 2019
2
0
10
0
All games.

Choppy stuttery graphics.
Movements and mouse movement is laggy

No matter what resolution or settings i use it is still laggy and choppy.
Tried different monitor, even tried 2 tvs.
Just cant play games like i can on other pcs ive used

Old pc
Gigabyte motherboard
Intel i5 6500
2x8gb crucial ram
Tried a gtx960 2gb
Then i tried a brand new rx570 8gb.
Same issues
Cx850m corsair power supply
Samsung 850evo 500gb ssd
Seagate hard drive 2tb

New build

Msi mortar b450m motherboard
Ryzen 5 - 2600x
A radeon vega64 8gb gpu
3000mhz tforce ram. 2x8gb DDR4
Just used the SSD, HDD and PSU out of a pc that had the same issues with gameplay
Deleted all partitions on the ssd and installed a fresh windows 10 on it.

What can it be ?
Wanted to ask before i go and purchase a new psu, hdd and ssd.

Using a samsung monitor, tried every res and every graphics settings, even the lowest possible and still the same.

Also lately when i connect 1080 screens, the screen crashes every 20 seconds.

Doesnt happen to my 1440p.

Is this a power supply issue or possibly bad cables? Cables from the psu are 24pin motherboard cable, cpu cable, gpu cable. And cable for the hdd and ssd.
 

drivinfast247

Notable
May 29, 2018
1,466
35
1,090
90
Doubtful it's the PSU, SSD or HDD.

Are you on latest BIOS? What about all other drivers? Are they up to date? Make sure the RAM is installed in correct slots and running at rated speeds/timings. Check that you have enabled PBO and XFR in the BIOS. Install HWINFO64 and check CPU temps. Install MSI Afterburner and monitor your in-game GPU and CPU temps.
 
Apr 18, 2019
2
0
10
0
Yes updated bios.
Installed latest gpu driver
Did all the windows updates, installed all the drivers for my motherboard
Ram is in 2nd and 4th slot.
Temps for cpu and gpu are good as gold.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS

Latest posts