Question Built my first pc, when I try to power it on the fans flicker then the whole pc turns off 10 secs later

Jul 6, 2022
1
0
10
0
PCPartPicker Part List: https://uk.pcpartpicker.com/list/MJT978

CPU: Intel Core i5-12400F 2.5 GHz 6-Core Processor (£163.99 @ Box Limited)
Motherboard: Gigabyte B660M DS3H AX DDR4 Micro ATX LGA1700 Motherboard (£119.27 @ Technextday)
Memory: TEAMGROUP T-FORCE VULCAN Z 16 GB (2 x 8 GB) DDR4-3200 CL16 Memory (£55.97 @ Overclockers.co.uk)
Storage: Western Digital Blue SN570 1 TB M.2-2280 NVME Solid State Drive (£72.78 @ Amazon UK)
Video Card: MSI Radeon RX 6600 8 GB MECH 2X Video Card (£319.99 @ Scan.co.uk)
Case: CiT F3 MicroATX Mini Tower Case (£27.34 @ Box Limited)
Power Supply: NZXT C (2020) 650 W 80+ Gold Certified Fully Modular ATX Power Supply (£84.99 @ Amazon UK)
Total: £844.33
Prices include shipping, taxes, and discounts when available
Generated by PCPartPicker 2022-07-06 20:23 BST+0100

I've tried starting it up with only CPU, psu, ram and fans plugged in but nothing works, I've ensured my ram is seated correctly and things are plugged in properly, tried CMOS reset and still nothing. At a bit of a loss for what to do so any help would be amazing.
 

Darkbreeze

Retired Mod
You realize you MUST have a graphics card installed in order for it to do anything, right? Your CPU has NO integrated graphics. Make sure you have your video cable connected to the graphics card and not the motherboard video outputs as well and triple check everything here:

 
Jun 8, 2022
51
16
45
2
I'm not too great with troubleshooting, but one thing came to mind: Try booting up with just one RAM stick at a time. Also try using different slots.
 

ASK THE COMMUNITY

TRENDING THREADS