[SOLVED] Built PC for the first time and installed Windows. Not detecting Wifi or cable Internet

mujmuj

Distinguished
Oct 11, 2015
193
5
18,585
0
I built PC for the first time and installed Windows 10. But it's still not detecting Wifi or cable Internet.

My laptop detects both wifi and cable wire connection. So it's not the network's problem.

Turning off and on again wifi router doesn't solve the problem.

Z690 motherboard
Crucial DDR5 4800 (two)
Radeon RX 6500
Crucial 2TB SSD PCle M.2


Is there something I have to plug onto my motherboard to make the network work?
 

Ralston18

Titan
Moderator
Drivers - very likely.

Will add some other suggestions along that line....

Run the built in Windows Troubleshooters. The troubleshooters may find and fix something.

Look in Device Manager for the PC in question: Any network adapters listed? (Be sure to check that under the View tab that "Show hidden devices" is checked.)

If a network device is listed, select that device and right click. A small menu will appear that, in turn allows you to manage drivers and make other related changes via Properties.

Using the PC's Command Prompt run "ipconfig /all" (without quotes) and post the results herein.

You should be able to copy and paste the output without any need to retype everything.

Failing the above:

On the PC: look in Reliability History and Event Viewer. Either one or both may be capturing some error code, warning, or even an informational event related to the network adapter, network connectivity, or network configuration.
 

ASK THE COMMUNITY

TRENDING THREADS