Question C&C Generals & Generals Zero Hour Installation errors on Windows 10.

Mar 8, 2019
2
0
10
0
Hello all,

I have been having issues with installing an old game of mine. About three years ago after I built my first gaming rig I tried to install my copy of C&C Generals and Generals Zero Hour (I have the Deluxe Edition). After the game completed installation it failed to launch. That was when I found out about Windows 10 and SecuROM surfing around various forums. After a while of pondering I decided to forget about it. I then uninstalled the game and moved on as I had other games to play. However, recently I have been feeling nostalgic and I wanted to try and see if I could try and get Generals to work again. The reason being is that I have heard of others who managed to get Generals to run on Windows 10. However, this time I ran into problems.
The Installation this time failed to install unlike the last time. Here is what happens. When the InstallShield Wizard starts and after you enter the product key and choose the file path it begins to start publishing "Product Information" this time instead of breezing by this, which it usually does, and uploading the game files from the CD it hangs at 72% for at least 5-9 minutes publishing product info. After this, it uploads the game data and I insert the second CD and it continues installing. Once the installation reaches 100% a window appears with the following.

-Severe: Unable to Launch: C\Users\HIGHPO~1\AppData\Local\Temp\{06F80017-8F98-4C94-B868-52358569FC32\DatGen.exe

After I click "OK" I then get this window right after......

-InstallShield 1628: Failed to Complete Installation. (I believe this is an error.)

The folder for Generals is in it's usual file location under Programs (x86). I started wondering what might be the problem. I realized that when I uninstalled it the first time three years ago, I stupidly uninstalled it incorrectly and I will be honest in saying I do not remember how I uninstalled it. All I remember is that I must have uninstalled it incorrectly. I believe it may be a registry issue compared to a faulty InstallShield since I have installed another old game using InstallShield on my PC which installed successfully without issue. However, I could be wrong also. I honestly do not know what is wrong.

Here are my specs if they are needed. (Ask me if you need more info.)
CPU: AMD FX-8350
Mobo: Asus M5A99FX PRO R2.0 ATX AM3
RAM: G.Skill Ripjaws X Series 8GB (x2 4GB) DDR3-1600 Memory
HDD: WD Black Series 4TB
Video Card: Sapphire Radeon R9 390 8GB Nitro

Just to let you all know I am a noob to troubleshooting on PC's and to building them, so I would appreciate the help. Any of you know what could be wrong here? Thanks!
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS