Question C++ Redistributable Errors

Aug 1, 2022
11
0
10
0
Hey all,

I bought the new MW2 and tried to play it after install yesterday. I received the 2019-2022 C++ Redistributable error (version 29334 for x86) that stopped the game from launching . Also with the package for amd64, same version. I initially thought this was a user error and went searching for a solution, but after doing some research it appears to be a legacy Windows error that has simply never been fixed.

The most common solution was to uninstall the downloaded C++ package in its entirety and then reinstall the 2019-2022 package to give it a clean slate. I tried that, but was stopped with an error that it could not find the redistributable. Since my PC has up to the 2015 version I decided to ignore it and simply download the 2019-2022 version. PC threw the exact same error when trying to download the redistributable package as when I tried to launch the game (on a resource that is unavailable). This time it told me that the older version cannot be removed and to contact my technical group.

I'm not sure what to do. I've tried uninstalling my previous versions (all of them) and been told that my computer couldn't find them, despite me being able to clearly see them running in my control panel. I can't download the 2019-2022 version and I can't access the file path of the older one's. I even tried using an uninstaller (Revo) in the hopes it might be able to brute force a reinstall, but it ran into the same issues and couldn't do it.

I've never had this issue ever in my entire time gaming on PC. If this is a Microsoft issue and I can't access my files, is there a solution or will I have to reformat my PC to fix it?

Cheers.
 
Are you on an admin account for windows? Did you try right click and run as admin?
It could just be that simple.
On the other hand it might be an issue with windows being screwed up and having an issue which would be very hard to solve.
 

ASK THE COMMUNITY