Calling forum experts

samsung11

Distinguished
Oct 9, 2011
5
0
18,510
0
In trying to find a solution to my hard drive problem i have found several forums and even replies on this forum , but each one has not been able to answer my question viz. (vista)
my laptop does not show my external drive
disk / device management also does not detect it
tried tweak ui -the box is checked to show drives

surely there is a solution to this problem , can anyone pls help , remember a definitive solution on this forum in the past , or any other forum that will be able to assist


very much appreciated
cheers
 

Pilk

Distinguished
Jan 6, 2010
519
0
19,010
21
Are you sure your external even works? Have you stripped it out of it casing and hooked it up directly to a system? Have you tried changing the USB cable to the drive as often these are faulty? Get back to us if you have done all of that.
 

Pilk

Distinguished
Jan 6, 2010
519
0
19,010
21
Are you sure your external even works? Have you stripped it out of it casing and hooked it up directly to a system? Have you tried changing the USB cable to the drive as often these are faulty? Get back to us if you have done all of that.
 

samsung11

Distinguished
Oct 9, 2011
5
0
18,510
0



yeah tx for the reply , have done all the dis and re connectings and the drive now shows a black line "unallocated" at computer - disc management. this apparently indicates that the h/d is corrupted or ....
i now need to figure out how and with which programme???? i can try recover the data.the seagate troubleshooting site was also most helpful to get me thisfar TX
 
Thread starter Similar threads Forum Replies Date
I Storage 2

ASK THE COMMUNITY

TRENDING THREADS