Question Can’t access BIOS after updating it, PC won’t boot to Windows and keyboard doesn’t allow me to access BIOS menu ?

Nov 25, 2021
1
0
10
0
Hey,

I’ve got a bit of an issue, I tried to update my bios to the latest version and made sure that I had read all iterations of the bios update so I could update in order. I have a Gigabyte GA-AB350- Gaming motherboard. I’ve had it 3 years now with no issues but wanted to update it so I could install a new 3rd gen ryzen cpu. I used a flash drive and updated to version F31 (for my first update). All seemed ok but then when the pc restarted it was stuck on the bios screen, this might not be an issue as I might need to check the boot drive to get into windows but my keyboard isn’t working to actually access the bios. I’ve tried plugging it in to all usb slots and nothing is working. I then changed the display lead from my graphics card into my motherboard and the bios screen isn’t even showing but when I plug back into my GPU the bios boot screen comes back.

I read quite a lot of forums suggesting to reset the cmos and hopefully that will allow me to get back into the bios but after doing that twice now and taking out the cmos battery I still have the same issue. Won’t get past the bios boot screen, won’t boot to windows and I can’t access the bios to see if my boot drive settings have changed. Any help would be greatly appreciated.
 

ASK THE COMMUNITY

TRENDING THREADS