Question Can’t boot new build

Mar 22, 2020
2
0
10
0
Here is the build

https://pcpartpicker.com/list/XgBXhg

Here is the problem- When I boot up, all fans spin and everything seems to be running fine but the computer gets stuck on the American Megatrends screen. When I try to press F1 to enter setup, or any other keys nothing happens. It shows that my keyboard/mouse, CPU, RAM, SSD are all recognized. If I try unplugging my GPU and using onboard HDMI, I get no video at all.

Here is what I’ve tried:
Testing each RAM stick individually
Resetting CMOS
Using a different keyboard
Using different USB ports for keyboard

I’m assuming that because the CPU is recognized on the American Megatrends screen, that it is installed properly.

Any help you give me would be greatly appreciated so I don’t have to bring it to a computer repair shop and pay a fortune.

Thank you.
 

R_1

Illustrious
Ambassador
the KF series CPU's have no iGPU so without the GPU you would not get anything on the screen so that at least is normal.
do you have a keyboard that is not USB? if not try the USB ports closest to the round keyboard jack.
 
Mar 22, 2020
2
0
10
0
::Fixed:: I figured I’d respond to this in case anyone else has the same problem. For some reason wireless usb keyboards were not working. I tried it with a wired one and it got me into bios. When I plugged the wired keyboard in, it actually made the wireless one start working.
 
Apr 13, 2020
3
0
10
0
Hey assclown lol I am having the same exact problem and I’ve tried similar things and none of them have worked. I have an Anne Pro 2 which is a usb wireless keyboard but I have it hooked up wired via usb. (It has the option to do wired/wireless) And it’s still not letting me through and I have no other keyboards to try.
 

ASK THE COMMUNITY

TRENDING THREADS