Question Can’t enable Turbo for i5 2400

amooei

Honorable
Dec 7, 2013
9
0
10,510
0
Hi there
I have 2 PCs running with Intel core i5 2400.
One has an Acer q67h2-am motherboard & another has an Intel DQ67SW.

The acer one shows my CPU like this:
https://www.mediafire.com/file/l9b9uxooe1vmsq9/F96CD4F2-0204-48FE-839E-2C782EF374AF.jpeg
As u see it’s turbo feature is enabled and runs at 3.10 Ghz.

But in my Intel board, it’s shown like this:
https://www.mediafire.com/file/l3v5fv3a4a1nh19/C5010F5E-9A34-47EA-8A6A-F27C3C89D41E.jpeg
It’s only 2.5 ghz, it’s also mentioned as 2400S, I don’t see “S” on Acer board.

Note that I used same proccessor in both boards, in Acer that’s like above one as 3.1 ghz but when I put it in intel, it shows 2.5 ghz & with a “S” end of its name.

I tried to change intel bios settings but that didn’t change anything, these are screen shots of my intel MB bios settings:
https://www.mediafire.com/file/8xtsvvw0v3vlxc8/5335D6E2-6A08-47B7-9677-81B7BF7DF0B7.jpeg
should I change anything there? And how can I gain my 3.10 Ghz boost?
Any help would be appreciated 🙏
 
Aug 22, 2018
26
0
40
1
Excuse me for my previous idiotic reply, try to change the settings to default, update bios, and finally if nothing works change the mobo
 
Last edited:

amooei

Honorable
Dec 7, 2013
9
0
10,510
0
Yes it’s latest bios version & I changed it to default settings too but still I see a 2.5 ghz cpu in windows 10.
If it’s mobo problem then why it’s showing 3.1 ghz as above screen shots?
 

ASK THE COMMUNITY