Question Can’t get Asus motherboard to recognize GPU

Aug 10, 2020
1
0
10
0
After days of unsuccessfully installing my GPU, I finally figured out what the problem may be. I think I need to change the default graphics output to PCIe on the BIOS menu but every time I try to save this setting it automatically switches back to auto on reboot. No matter what I try I cannot get the GPU to show up in Device Manager. All of the components are new or manufacturer refurbished. This is the first PC I built myself and I really want to figure this out and move past this frustration!

ASUS TUF B365M-PLUS
Geforce GTX 970 GPU
i5-8400 2.8 GHz CPU
Gskill 16 GB RAM
EVGA 650W PSU
 

egda23

Upstanding
Jun 14, 2020
415
72
290
15
After days of unsuccessfully installing my GPU, I finally figured out what the problem may be. I think I need to change the default graphics output to PCIe on the BIOS menu but every time I try to save this setting it automatically switches back to auto on reboot. No matter what I try I cannot get the GPU to show up in Device Manager. All of the components are new or manufacturer refurbished. This is the first PC I built myself and I really want to figure this out and move past this frustration!

ASUS TUF B365M-PLUS
Geforce GTX 970 GPU
i5-8400 2.8 GHz CPU
Gskill 16 GB RAM
EVGA 650W PSU
Have you correctly connected the POWER CONNECTORS to your GTX 970 GPU ?
 
Aug 11, 2020
2
0
10
0
Yes the fans begin to run when it boots up. I also inserted my old GTX 750, which doesn’t require extra power, and The motherboard was unable to recognize this as well. I don’t think my graphics output settings are being changed in BIOS because every time I go back the graphics is set back to auto.
 

ASK THE COMMUNITY

Latest posts