Question Can a new BIOS update make RAM compatibility worse?

MadsModsat

Commendable
I have a 9th Gen Core i3 9100F CPU I have been keeping as a spare, from a while back when my i9 had to be RMAed.

I also have two spare sets of RAM, which I was using with the 9100F. Both sets are Kingston HyperX Fury 2666MHz 2 x 8 GB (HX426C16FB2K2/16).

They are two sperate 2x8GB kits, bought seperately, but they were running perfectly fine in a 4x8 setup with the 9100F at 2666MHz, eventhough the max supported frequency of the 9100F is 2400MHz.

But since I have a z-series chipset, the frequency was never an issue and although it is usually advised against running two seperate kits together, it never presented a problem during the approximately 4 weeks I was using that setup.

Since my PC with the i9 has been running perfectly fine for a while, I thought I'd sell the two spare sets of RAM and the i3 9100F CPU.

To make sure everything was still in working order, I first ran MemTest86 on the two sets of RAM individually and then in a 4x8 GB setup, using my i9 CPU.

All 3 configurations ran 8 complete passes each, with no errors.

Today I installed the i3 and one of the Kingston HyperX sets (2x8 only), and I couldn't get my computer to boot - I did of course reset BIOS and prepare everything for an easy switch before I shut it down.

Since I couldn't get it to boot, even after taking out the battery for 10 minutes, I tried booting on just one stick of RAM, and it worked perfectly fine.

I then setup all relevant BIOS settings, saved and shut it down after letting it boot to Windows. I figured the BIOS defaults would now be tuned and I could just mount the second RAM stick.

But no matter what I do, I can not make it boot with more than 1 stick of RAM.

I booted into Windows on one stick of RAM and ran Intel Processor Diagnostic Tool, and the CPU passed with no errors.

I have also tried a set of Corsair Vengeance LPX 3333MHz RAM 2x16GB RAM, which defaults to 2133MHz, well below the 2400MHz max supported memory frequency of the 9100F.

I can make it boot with one of the Corsair sticks, but not two, no matter what settings I try for memory in the BIOS settings.

Both XMP and non-XMP settings have been tested, with no positive result.

I have screendumps of the i3 9100F running with the 4x8GB HyperX Fury at 2666MHz, so I'm absolutely positive it used to work.
I also have AIDA64 memory benchmark of that configuration, and even some 3DMark runs.

I even have screendumps of the 9100F running with the 2x16GB Corsair RAM at 3333MHz.

Looking at the screendumps I have of the computer running with the 9100F and the 4 Kingston HyperX stick, the only difference I notice, is that I was on an earlier BIOS build at the time. I was running BIOS 1302 and now I'm on BIOS version 1401.

I have tried the BIOS in both Legacy and UEFI mode. Fast Boot both on / off.

Everything else is identical, so after this lenghty explanation, my question is :

Can it really be the updated BIOS, which makes it completely impossible for me to run the 9100F with any of the three RAM kits I have, due to compatibility issues?

The CPU has just been sitting on my desk in its original packaging, so I don't suspect it has been damaged, and it has been handled carefully. You never know, of course, but I don't see how it should have been damaged.

All the RAM still works flawlessly with my 9900K with all kinds of settings - I even tested the Kingston 2666MHz at 2400MHz, and it runs completely as expected, as well as at 2133MHz. So in that sense, it should be able to run at or below the max 2400MHz of the i3.

It is not extremely important, I'll just don't sell the CPU, but I'm very curious with regards to what the problem could be.

The complete setup is in my signature, but I'll post it here as well

i3 9100F / i9 9900K
ASUS RoG Maximum XI Hero (WiFi) Z390 chipset, BIOS 1401 (1302 initially)
ASUS RoG Strix RTX 2080 Super OC Edition
Kingston HyperX Fury 2x8GB - HX426C16FB2K2/16 (Two sets of these)
Corsair Vengeance LPX 2133 / 3333MHz 2x16GB (I use these daily)
Seasonic Prime Ultra Platinum 850
Samsung 970 EVO Plus (500GB + 1TB)
Samsung 860 EVO 1 TB SATA3
2 x 6TB SATA3 HDDs

I think that's all, thanks a lot in advance for any replies.

(It is a bit late here, so if it seems like I'm not responding, I might have gone to bed, but I'll be looking forward to any comments there might be) :p

EDIT :

I almost forgot - I have tried several of the RAM stick, although not all, in the different DIMM slots, and none of them appear to be faulty, the DIMMs i mean.
 
Last edited:
The board, the CPU, the RAM itself - it's all compatible with one another and the RAM is even on that mobos QVL list. The only likely culprit is the BIOS, if everything was working up until the BIOS change then the obvious suspect is of course the BIOS. It's odd you're not able to fix it after going back to the inital BIOS you were at when it did work, but the issue doesn't sound like it's with the CPU itself, unless you damaged one of the contacts on the bottom of the CPU. Only way to find out if it works still is to try it on another board, but that's not really worth your time and money now is it?.

I say sell it, doesn't seem like a CPU issue from your story, more of a BIOS microcode issue, which the next owner of that chip might not deal with.

Have you also tried taking out the CMOS battery, and holding the power button to drain the residual power in the capacitors? The ram slots has its own capacitors I believe so best to try that as well.
 

MadsModsat

Commendable
Thanks a lot for your reply, it is much appreciated.

When I bought the Corsair RAM, I made sure they were compatible.
Later on, I purchased the Kingston RAM and the 9100F making sure they specifically were compatible with my motherboard, since I initially had issues with the new build - and the parts were bought for troubleshooting. So I didn't think I would run in to this kind of problems.

There are no marks, scratches or anything of that kind on the contact points underneath the 9100F

I would be surprised if there were bent pins in the MB socket, since the 9900K runs perfectly fine, with any kind of RAM setup - both prior to and after the CPU swap today.

One thing I wasn't clear about is, that I didn't actually try to revert to BIOS 1302, the one that was working.

I know that would be the thing to do, but I have saved multiple BIOS profiles for my current setup, and they are wiped when updating to a new BIOS or reverting to a previous one. I'm supposed to be able to export the profiles to a USB stick, but for some reason I seem to be too dumb to make it work (FAT32 formatted of course and smaller than 4GB), or maybe I didn't try hard enough as it didn't seem important at the time.

So the reason why I didn't do the obvious and revert to the previous BIOS version is, that it is simply too much work, it is not THAT important that I get it working... - but I have never since I began building computers in the late 90s come across this issue before - I know new BIOS versions don't always improve things, but this problem is a first for me - so my curiosity is strong :D

But I'm actually considering getting rid of the AiO, so I have a Noctua NH-D15 Chromax.Black on the way I'll be testing over the next few days, it should arrive tomorrow - so since I'll be swapping CPU cooler again soon, maybe I should have another go at exporting the BIOS profiles and then revert to version 1302...

-I am very interested in figuring this out, to be honest, although it is not incredibly important.
 
Last edited:

MadsModsat

Commendable
I finally spend an extra second and figured out how to save my BIOS setup files to a USB stick, so I reverted to BIOS 1302, reinstalled the i3 9100F, and still it refuses to work with more than 1 stick of RAM. I didn't do any experimenting or troubleshooting this time though, it has already taken too much of my time.

I paid just under USD $90 for the i3 9100F new, and I was planning to sell it for $45. But if I sell it, and the buyer has the same problems, then I'll have to pay the money back, as well as pay for any related shipping costs if I can't sell it locally.

So in a very short while, it can end up costing me money, and $45 dollars is just too little to be worth it. I'll keep it as a spare, in case my 9900K decides to give up on life for some reason.

All three sets of RAM are still working with my 9900K, so I'll see if I can sell the two Kingston kits.

I'm still puzzled by what has caused this. The i3 was used for just under 4 weeks. Then put directly back into the original packaging, and I never touched it again until yesterday when I wanted to make sure it was functional before selling it.

The MB socket is fine, unless an 9900K can run with bent pins that the 9100F can't - I'd say that's highly unlikely.

I have never handled the i3 in any other ways than holding on to the sides, never the bottom.

I accidentally bent a pin on an Intel P4 Northwood C back when they were hot stuff - I've never damaged a CPU since then - that doesn't mean I can't accidentally do it, but I'm usually capable of being cautious around CPUs.

I guess I'll never figure this out, but I'm still very interested if anyone has a good suggestion to what could be causing this.
 

ASK THE COMMUNITY

TRENDING THREADS